1. 程式人生 > >HDU-1532(網路最大流)

HDU-1532(網路最大流)

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
InputThe input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch. 
OutputFor each case, output a single integer, the maximum rate at which water may emptied from the pond. 
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output
50

/*
 *
 題意:
 給你n條邊和m個點,問你1-m的網路最大流是多少?

 題解:
 EK(Edmond—Karp)演算法
 */
#include <queue>  
#include<string.h>  
#include<iostream>
using namespace std;
#define INF 0x3f3f3f3f
int mp[205][205];         //記錄殘留網路的容量  
int flow[205];			  //標記從源點到當前節點實際還剩多少流量可用  
int pre[205];             //標記在這條路徑上當前節點的前驅,同時標記該節點是否在佇列中  

queue<int>Q;
int n, m;

int BFS(int Start, int End)
{
	while (!Q.empty())
	{
		Q.pop();
	}
	//初始化前置點
	for (int i = 1; i <= m; i++)
	{
		pre[i] = -1;
	}
	pre[Start] = 0;
	flow[Start] = INF;     //初始的時候最大流設定為無限大
	Q.push(Start);
	while (!Q.empty())
	{
		int Index = Q.front();
		Q.pop();
		if (Index == End)
		{
			break;
		}
		for (int i = 1; i <= n; i++)
		{
			//如果當前剩餘流量大於0,並且之前沒有訪問過該點
			if (i != Start && mp[Index][i] > 0 && pre[i] == -1)
			{
				pre[i] = Index;   //當前點的前置是Index
				//更新源點到i點剩餘的流量
				flow[i] = min(mp[Index][i], flow[Index]);

				Q.push(i);
			}
		}
	}
	// 如果不可以到達最後的點
	if (pre[End] == -1)
	{
		return -1;
	}
	else
	{
		//返回起點到最後點剩餘的流量
		return flow[End];
	}

}


int MaxFlow(int Start, int End)//返回 start -> End 的最大流
{
	int ans = 0;
	int increaseflow = 0;
	//當前是否可以走到最後
	while ((increaseflow = BFS(Start, End)) != -1)
	{
		int k = End;
		//下面程式碼用來修改地圖流量
		while (k != Start)
		{
			int Front_Index = pre[k];		//Front_Index為k點的上一個點,利用前驅尋找路徑
			mp[Front_Index][k] -= increaseflow;		//改變正向邊的容量  
			mp[k][Front_Index] += increaseflow;	//改變反向邊的容量  
			k = Front_Index;
		}
		ans += increaseflow;
	}
	return ans;
}


int main()
{
	while (cin >> n >> m)
	{
		int Start, End;
		int Val;
		memset(flow, 0, sizeof(flow));
		memset(mp, 0, sizeof(mp));
		for (int i = 0; i < n; i++)
		{
			cin >> Start >> End >> Val;
			//如果起點終點相同則continue
			if (Start == End)
				continue;
			mp[Start][End] += Val;
		}

		cout << MaxFlow(1, m) << endl;

	}


	return 0;
}