1. 程式人生 > >HDU 4027 (線段樹區間更新)

HDU 4027 (線段樹區間更新)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 24587    Accepted Submission(s): 5821


 

Problem Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8

Sample Output

Case #1: 19 7 6

Source

兩種操作,一種是[l,r]間所有值開根號,在資料範圍內一直開根號最後都會變成1,所有如果區間和為 l-r+1 就可以跳過 

另一種就是求區間和 

需注意的點: 輸入的 l 可能比 r 小 需要swap一下  ;資料較大用 long long

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn =  1e5+10  ;
const int inf =	0x3f3f3f3f;

struct node{
    ll l,r;
    ll sum;
}tree[maxn<<2];

int kase=0;
int n,m,t;
int p,q;
int x,y;
ll a,b,c;
int val = 1;
ll ans = 0;
void pushup(int k)
{
    tree[k].sum = tree[k<<1].sum+tree[k<<1|1].sum;
}
void build(int l,int r,int k)
{
    tree[k].l = l;  tree[k].r = r;
    if(l == r){ scanf("%lld",&tree[k].sum); return ;  }
    int mid = (l+r)>>1;
    build(l,mid,k<<1);
    build(mid+1,r,k<<1|1);
    pushup(k);
}
void updata(int k)
{
    if(tree[k].l==tree[k].r)
    {
       tree[k].sum = sqrt(tree[k].sum );
       return ;
    }
    if(a <= tree[k].l && b >= tree[k].r && tree[k].sum == tree[k].r-tree[k].l+1)
    {
      return ;
    }
    
    int mid = (tree[k].l+tree[k].r)>>1;
    if(a<=mid){  updata(k<<1); }
    if(b>mid){  updata(k<<1|1);  }
    pushup(k);
}
void query(int k)
{
    if(a <= tree[k].l && b >= tree[k].r)
    {
      ans +=tree[k].sum ;
      return ;
    }
    int mid = (tree[k].l+tree[k].r)>>1;
    if(a <= mid){ query(k<<1);}
    if(b > mid){ query(k<<1|1);}
}
int main()
{
  while(scanf("%d",&n)!=EOF)
  {
    build(1,n,1);
    scanf("%d",&m);
    printf("Case #%d:\n",++kase);
    while(m--)
    {
      scanf("%d%lld%lld",&q,&a,&b);
      if(a>b) swap(a,b);
      if(q)
      {
        ans = 0;
        query(1);
        printf("%lld\n",ans);
      }
      else  updata(1);
    }
    printf("\n");
  }
}