1. 程式人生 > >POJ 1088: 滑雪(經典 DP+記憶化搜索)

POJ 1088: 滑雪(經典 DP+記憶化搜索)

esp roman ted font eof 個人 algorithm set str

滑雪
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 74996 Accepted: 27818

Description

Michael喜歡滑雪百這並不奇怪, 由於滑雪的確非常刺激。但是為了獲得速度,滑的區域必須向下傾斜,並且當你滑到坡底,你不得不再次走上坡或者等待升降機來載你。Michael想知道載一個區域中最長底滑坡。區域由一個二維數組給出。數組的每一個數字代表點的高度。以下是一個樣例
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一個人能夠從某個點滑向上下左右相鄰四個點之中的一個,當且僅當高度減小。在上面的樣例中。一條可滑行的滑坡為24-17-16-1。當然25-24-23-...-3-2-1更長。其實,這是最長的一條。

Input

輸入的第一行表示區域的行數R和列數C(1 <= R,C <= 100)。以下是R行,每行有C個整數,代表高度h。0<=h<=10000。

Output

輸出最長區域的長度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25


中文題什麽的再也不用操心題目都看不懂了。

。23333


#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<cmath>

using namespace std;

const int M = 105;
int n, m;
int map[M][M];
int ans[M][M];
int dx[] = {1, -1, 0, 0};
int dy[] = {0, 0, -1, 1};

int dp(int x, int y)
{
    int max = 0;
    if( ans[x][y]>0 )
        return ans[x][y];
    for(int i=0; i<4; i++)  //四個方向
    {
        int xx = x + dx[i];
        int yy = y + dy[i];
        if( xx>=1 &&xx<=n &&yy>=1 &&yy<=m )  //邊界
        {
            if( map[x][y] > map[xx][yy] )    //從高到低才合法
            if ( max < dp( xx, yy ) )
                max = dp( xx, yy );
        }
    }
    return ans[x][y] = max + 1;
}

int main()
{
    while( scanf( "%d%d", &n, &m ) !=EOF )
    {
        memset( map, 0, sizeof(map) );
        memset( ans, 0, sizeof(ans) );
        for( int i=1; i<=n; i++ )
            for( int j=1; j<=m; j++ )
                scanf( "%d", &map[i][j] );
        for( int i=1; i<=n; i++ )
            for( int j=1; j<=m; j++ )
                dp( i, j );
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                if( ans[1][1] < ans[i][j] )
                    ans[1][1] = ans[i][j];
        printf("%d\n", ans[1][1]);
    }

    return 0;
}





POJ 1088: 滑雪(經典 DP+記憶化搜索)