1. 程式人生 > >POJ 1088 滑雪【經典DP】

POJ 1088 滑雪【經典DP】

滑雪
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 96358 Accepted: 36539

Description

Michael喜歡滑雪百這並不奇怪, 因為滑雪的確很刺激。可是為了獲得速度,滑的區域必須向下傾斜,而且當你滑到坡底,你不得不再次走上坡或者等待升降機來載你。Michael想知道載一個區域中最長底滑坡。區域由一個二維陣列給出。陣列的每個數字代表點的高度。下面是一個例子 
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一個人可以從某個點滑向上下左右相鄰四個點之一,當且僅當高度減小。在上面的例子中,一條可滑行的滑坡為24-17-16-1。當然25-24-23-...-3-2-1更長。事實上,這是最長的一條。

Input

輸入的第一行表示區域的行數R和列數C(1 <= R,C <= 100)。下面是R行,每行有C個整數,代表高度h,0<=h<=10000。

Output

輸出最長區域的長度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

Source


dp[x][y]表示從(x,y)為起點的最長滑雪距離.

AC程式碼:

/**
  * 行有餘力,則來刷題!
  * 部落格連結:http://blog.csdn.net/hurmishine
  *
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=100+5;
int a[maxn][maxn];
int dp[maxn][maxn];
int n,m;
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int DP(int x,int y)
{

    if(dp[x][y])
        return dp[x][y];
    int ans=0;
    for(int i=0;i<4;i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(xx<0||xx>=n||yy<0||yy>=m)
            continue;
        if(a[xx][yy]<a[x][y])
            ans=max(ans,DP(xx,yy));
    }
    dp[x][y]=ans+1;
    return dp[x][y];
}
int main()
{
    while(cin>>n>>m)
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                cin>>a[i][j];
        }
        memset(dp,0,sizeof(dp));
        int maxx=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                maxx=max(maxx,DP(i,j));
            }
        }
        cout<<maxx<<endl;
    }
    return 0;
}

參考部落格: