1. 程式人生 > >uva 12083 Guardian of Decency (二分圖匹配)

uva 12083 Guardian of Decency (二分圖匹配)

eas eof aid spa ams oba school eache lib

uva 12083 Guardian of Decency

Description
Frank N. Stein is a very conservative high-school teacher. He wants to take some of his students on an excursion, but he is afraid that some of them might become couples. While you can never exclude this possibility, he has made some rules that he thinks indicates a low probability two persons will become a couple:

Their height differs by more than 40 cm.
They are of the same sex.
Their preferred music style is different.
Their favourite sport is the same (they are likely to be fans of different teams and that would result in fighting). 

So, for any two persons that he brings on the excursion, they must satisfy at least one of the requirements above. Help him find the maximum number of persons he can take, given their vital information.

Input
The first line of the input consists of an integer T ≤ 100 giving the number of test cases. The first line of each test case consists of an integer N ≤ 500 giving the number of pupils. Next there will be one line for each pupil consisting of four space-separated data items:

an integer h giving the height in cm;
a character ‘F‘ for female or ‘M‘ for male;
a string describing the preferred music style;
a string with the name of the favourite sport. 

No string in the input will contain more than 100 characters, nor will any string contain any whitespace.

Output
For each test case in the input there should be one line with an integer giving the maximum number of eligible pupils.

Sample Input

2
4
35 M classicism programming
0 M baroque skiing
43 M baroque chess
30 F baroque soccer
8
27 M romance programming
194 F baroque programming
67 M baroque ping-pong
51 M classicism programming
80 M classicism Paintball
35 M baroque ping-pong
39 F romance ping-pong
110 M romance Paintball

Sample Output

3
7

題目大意:Frank是一個思想有些保守的老師。有一次,他須要帶一些學生出去旅遊,但又怕當中有一些學生在旅途中萌生愛意。

為了減少這樣的事情發生的概率,他決定確保帶出去的隨意兩個學生至少要滿足以下4條中的一條:

1)身高相差大於40厘米。

2)性別同樣。

3)最喜歡的音樂屬於不同的類型。

4)最喜歡的體育比賽同樣。

你的任務是幫助Frank挑選盡量多的學生,使得隨意兩個學生至少滿足上述條件中的一條。

解題思路:將能夠匹配的男女建邊。然後就是一個二分圖匹配問題。

最後用n減去求出的最大的匹配。就是答案。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;

typedef long long ll;
const int N = 505;
const int M = 250005;
struct Node {  
    int height, id;  
    char sex[5], music[105], sport[105];  
}stu[N];  
int n, e, ans;
int head[N], pnt[M], Next[M], rec[N];  
bool S[N], T[N];  

void init() {
    e = 0;  
    memset(head, -1, sizeof(head));  
    memset(rec, 0, sizeof(rec));  
    ans = 0;
}

bool check(int i,int j) {  
    if(abs(stu[i].height - stu[j].height) > 40) return false;  
    //身高差超過40cm
    if (strcmp(stu[i].music, stu[j].music)) return false;
    //喜歡的音樂類型同樣
    if (!strcmp(stu[i].sport, stu[j].sport)) return false;
    //喜歡的體育類型不同
    return true;  
}

void addEdge(int u,int v) {  
    pnt[e] = v;
    Next[e] = head[u];
    head[u] = e++;  
}  

void input() {
    scanf("%d", &n);  
    for(int i = 1; i <= n; i++) { 
        scanf("%d %s %s %s", &stu[i].height, stu[i].sex, stu[i].music, stu[i].sport);  
    }
    for(int i = 1; i <= n; i++) {  
        if(stu[i].sex[0] == ‘F‘) continue; //邊僅僅能從男生到女生 
        for(int j = 1; j <= n; j++) {
            //將能夠匹配的男女建邊
            if(stu[j].sex[0] == ‘F‘ && check(i,j)) addEdge(i,j);  
        }
    }
}

bool match(int u) {  
    S[u] = 1;  
    for(int i = head[u]; i != -1 ; i = Next[i])  
        if(!T[pnt[i]]) {  
            T[pnt[i]] = 1;  
            if(!rec[pnt[i]] || match(rec[pnt[i]])) {  
                rec[pnt[i]] = u;  
                return true;  
            }  
        }  
    return false;  
}  

void hungary() {
    for(int i = 1; i <= n; i++) {  
        memset(S, 0, sizeof(S));  
        memset(T, 0, sizeof(T));  
        if(match(i)) ans++;  
    }
}

int main() {  
    int T;
    scanf("%d", &T);  
    while(T--) {  
        init();
        input();
        hungary();
        printf("%d\n", n - ans);  
    }  
    return 0;  
}

uva 12083 Guardian of Decency (二分圖匹配)