1. 程式人生 > >zoj 1530 Find The Multiple

zoj 1530 Find The Multiple

while 序列 can rmi table main get con n)

Find The Multiple

Time Limit: 2 Seconds Memory Limit: 65536 KB Special Judge

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.


Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero (0) terminates the input.


Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.


Sample Input

2
6
19
0


Sample Output

10
100100100100100100
111111111111111111


Source: Asia 2002, Dhaka (Bengal)

題意:給你一個數n,讓你找n的倍數m,m的十進制中只能有1和0,問最小的m是幾。

思路若沒有是n的倍數的條件,如何構造01序列?開一個隊列,先把1放進去。然後取出1,把1*10,1*10+1放進去,以此類推是n的倍數只需要判斷一下即可,但答案可能爆long logn,所以用同余定理 若a%b=c,那麽ax%b=cx%b (x!=0),用字符數組記錄01序列,同時記錄這個01序列%n的余數。還有一個問題,空間消耗巨大,

還是用同余定理:如果a%n=c,b%n=c,a<b,那麽這個時候b就不用入隊了,因為答案只看余數

#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
struct nond{
    string s;
    int mod;
}cur,net;
int n;
bool vis[1000001];
int main(){
    while(1){
        queue<nond>que;
        memset(vis,0,sizeof(vis));
        scanf("%d",&n);
        if(n==0)    break;
        cur.s="1";cur.mod=1;
        que.push(cur);
        while(!que.empty()){
            cur=que.front();
            que.pop();
            net.mod=(cur.mod*10)%n;
            net.s=cur.s+0;
            if(net.mod==0){
                cout<<net.s<<endl;
                break;
            }
            if(!vis[net.mod]){
                que.push(net);
                vis[net.mod]=1;
            }
            net.mod=(cur.mod*10+1)%n;
            net.s=cur.s+1;
            if(net.mod==0){
                cout<<net.s<<endl;
                break;
            }
            if(!vis[net.mod]){
                que.push(net);
                vis[net.mod]=1;
            }
        }
    }
    
}

zoj 1530 Find The Multiple