1. 程式人生 > >poj2248 Addition Chains 叠代加深搜索

poj2248 Addition Chains 叠代加深搜索

font == sed sca enter win spl length mes

Addition Chains

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5454 Accepted: 2923 Special Judge

Description

An addition chain for n is an integer sequence <a0, a1,a2,...,am="">with the following four properties:
  • a0 = 1
  • am = n
  • a0 < a1 < a2 < ... < am-1
    < am
  • For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.

Input

The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.

Sample Input

5
7
12
15
77
0

Sample Output

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77

Source

Ulm Local 1997 提交地址 : poj 依次搜索一位k, 枚舉之前的i, j, 把a[i] + a[j] 加到a[k]的位置上, 然後接著搜索; 剪枝:盡量從達到小枚舉i,j讓序列的數盡快逼近n; 為了不重復搜索,用一個bool數組存a[i] + a[j] 是否已經被搜過; 然後因為答案的深度很小, 所以一發叠代加深; 這樣差不多A了; 這個代碼在poj上通過但在UVa上Re, 看到的大佬可以幫我找錯! 代碼奉上: 技術分享圖片
//By zZhBr
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int n;
int ans;

int a[1100];

bool use[1005];
bool DFS(int stp)
{
    memset(use, 0, sizeof use);
    
    if(stp > ans)
    {
        if(a[ans] == n) return 1;
        else return 0;
    }
    
    for(register int i = stp - 1 ; i >= 1 ; i --)
    {
        for(register int j = i ; j >= 1 ; j --)
        {
            if(a[i] + a[j] > n) continue;
            if(!use[a[i] + a[j]])
            {
                if(a[i] + a[j] <= a[stp - 1]) return 0;
                use[a[i] + a[j]] = 1;
                a[stp] = a[i] + a[j];
                if(DFS(stp + 1)) return 1;
                a[stp] = 0;
                use[a[i] + a[j]] = 0;
            }
        }
    }
}

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        if(n == 0) return 0;
        if(n == 1)
        {
            printf("1\n");
            continue;
        }
        if(n == 2)
        {
            printf("1 2\n");
            continue;
        }
        a[1] = 1;a[2] = 2;
        for(ans = 3 ; !DFS(3) ; ans ++);
        for(register int i = 1 ; i <= ans ; i ++)
        {
            printf("%d ", a[i]);
        }
        printf("\n");
        memset(a, 0, sizeof a);
    }
    return 0;
}
zZhBr

poj2248 Addition Chains 叠代加深搜索