1. 程式人生 > >HDU 4496 D-City(反向並查集)

HDU 4496 D-City(反向並查集)

Problem Description

Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

 

 

Input

First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 

 

 

Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.

 

 

Sample Input

 

5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4

 

 

Sample Output

 

1 1 1 2 2 2 2 3 4 5

Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

  題意是有n個點,m條邊,剛開始這些邊都是連著的,然後按順序逐一破壞這些邊,然後讓你輸出每破壞一次圖中還剩幾個集合,剛開始肯定是有一個集合的,最後都破壞完了就是n個集合了。

思路:反向考慮,正向刪邊化為反向加邊,利用並查集,每次加邊後聯通塊數減1

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 100005
struct edge
{
    int x,y;
}edge[maxn];
int father[maxn];
int ans[maxn];
int n,m,sum;
void init()
{
    for(int i=0;i<n;i++)
    father[i]=i;
}
int find(int x){
  if(father[x]!=x)
  father[x]=find(father[])
}
void unoin(int x,int y)
{
    int r1=find(x);
    int r2=find(y);
    if(r1!=r2)
    {father[r2]=r1;
    sum--;
    }
}

int main()
{while(~scanf("%d%d",&n,&m))
{
    init();
    memset(ans,0,sizeof(ans));
    sum=n;
    for(int i=0;i<m;i++)
    scanf("%d%d",&edge[i].x,&edge[i].y);
    for(int i=m-1;i>=0;i--)
    {
        ans[i]=sum;
        unoin(edge[i].x,edge[i].y);
    }
    for(int i=0;i<m;i++)
    printf("%d\n",ans[i]);
}
return 0;

}