1. 程式人生 > >HDU 1213 How Many Tables(並查集求強連通分量)

HDU 1213 How Many Tables(並查集求強連通分量)

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

 

Sample Input

 

2 5 3 1 2 2 3 4 5 5 1 2 5

 

 

Sample Output

 

2 4

 

 

Author

Ignatius.L

 

 

Source

杭電ACM省賽集訓隊選拔賽之熱身賽

   現在給你由1到N個數字組成的M對整數對,問你有多少個連通分量。每對整數X和Y(X不等於Y)表示X和Y在一個連通分量裡面。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 1500
int n,m,t,cnt;
int father[maxn];
int find(int x)
{
    if(father[x]!=x)
    father[x]=find(father[x]);
    return father[x];
}
void unionn(int x,int y)
{
    int r1=find(x);
    int r2=find(y);
    if(r1!=r2)
    {father[r2]=r1;
    cnt--;
    }
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {scanf("%d%d",&n,&m);
    cnt=n;
    for(int i=1;i<=n;i++)
    father[i]=i;
    for(int i=1;i<=m;i++)
     {int u,v;
     scanf("%d%d",&u,&v);
     unionn(u,v);

     }
     printf("%d\n",cnt);
    }
    return 0;
}