1. 程式人生 > >HDU3829:Cat VS Dog(最大獨立集)

HDU3829:Cat VS Dog(最大獨立集)

Cat VS Dog

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 4751    Accepted Submission(s): 1757

Description:

The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input:

The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

Output:

For each case, output a single integer: the maximum number of happy children.

Sample Input:

1 1 2 C1 D1 D1 C1   1 2 4 C1 D1 C1 D1 C1 D2 D2 C1

Sample Output:

1
3

Hint:

Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.   題意: 每個人都會喜歡一隻貓(狗),相應的他會討厭一隻狗(貓),問現在要去掉多少貓or狗,可以讓最多的人滿意。   題解:
我一開始想的是對人和動物建圖,讓一個人快樂的話,就是留住一個動物以及去掉一個動物,但這樣有點複雜,沒做出來... 然後看了下其它的題解,發現如果一個人喜歡一隻貓,另外一個人討厭一隻貓的話,那麼就不可能讓這兩個人同時滿意,最多隻能讓一個人滿意。 這樣問題就可以轉化為最大獨立集了,最大獨立集的意思就是選取儘量多的點,並且這些點互不相鄰。 想到這裡建圖就比較好建了,對人人建圖。   程式碼如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define mem(x) memset(x,0,sizeof(x))
using namespace std;

const int N = 505;
int n,m,p,ans;
char like[N][5],dlike[N][5]; //這裡我一開始陣列開的是4,WA了,開成5就AC了 
int check[N],match[N],link[N][N];

inline int dfs(int x){
    for(int i=1;i<=p;i++){
        if(link[x][i] && !check[i]){
            check[i]=1;
            if(!match[i] || dfs(match[i])){
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main(){
    while(~scanf("%d%d%d",&n,&m,&p)){
        mem(match);mem(link);ans=0;
        for(int i=1;i<=p;i++){
            scanf("%s%s",like[i],dlike[i]);
        }
        for(int i=1;i<=p;i++)
            for(int j=1;j<=p;j++)
                if(strcmp(like[i],dlike[j])==0 || strcmp(like[j],dlike[i])==0) link[i][j]=1;
        for(int i=1;i<=p;i++){
            mem(check);
            if(dfs(i)) ans++;
        }
        printf("%d\n",p-ans/2);
    }
    return 0;
}