1. 程式人生 > >POJ - 3342 Party at Hali-Bula 樹形dp

POJ - 3342 Party at Hali-Bula 樹形dp

Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input

The input consists of multiple test cases. Each test case is started with a line containing an integer n

(1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output

For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input

6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0

Sample Output

4 Yes
1 No
題解: 這個題在輸出最大值的情況下,讓你判斷這個值是否唯一確定,因為dp[u][0] = max(dp[son][1],dp[son][0]) 假設我們不取這個點時值更大,那麼如果對於某一個子代存在dp[son][1] == dp[son][0] 的情況 那麼這是取哪個值都一樣,最大值就不唯一
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <map>
using namespace std;
const int N = 200 + 10;
vector<int> v[N];
int n;
int dp[N][2], in[N];
bool vis[N][2];
map<string, int> mp;
void dfs(int u) {
	dp[u][0] = 0;
	dp[u][1] = 1;
	for(int i = 0; i < v[u].size(); ++i) {
		int to = v[u][i];
		dfs(to);
		dp[u][1] += dp[to][0];
		dp[u][0] += max(dp[to][0], dp[to][1]);
		if(dp[to][0] == dp[to][1]) vis[u][0] = 1;
	}
}
int main() {
	int num, id, idboss, to, cnt;
	string s, boss;
	while(~scanf("%d", &n) && n) {
		mp.clear();
		cnt = 1;
		for(int i = 1;i <= n; i++) v[i].clear();
		memset(vis, 0, sizeof(vis));
		cin >> s;
		mp[s] = 1;
		for(int i = 1; i < n; i++) {
			cin >> s >> boss;
			if(!mp[s]) mp[s] = ++cnt; 
			if(!mp[boss]) mp[boss] = ++cnt;
			id = mp[s], idboss = mp[boss];
			v[idboss].push_back(id);
		}
		dfs(1);
		int flag = 0;
		printf("%d ", max(dp[1][0], dp[1][1]));
		if(dp[1][0] == dp[1][1]) flag = 1;
		for(int i = 1;i <= cnt; i++) {
			if(dp[i][0] >= dp[i][1] && vis[i][0]) {
				flag = 1;
				break;
			}
		}
		if(flag) printf("No\n");
		else printf("Yes\n");
	}
	return 0;
}