1. 程式人生 > >pat1002 甲級 A+B for Polynomials (25 分)

pat1002 甲級 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

就是多項式求和,k為多項式係數(一開始以為是非零項什麼鬼),n為指數,An為係數。

一開始因為,輸出時陣列沒有開到1001錯了幾次。

後面又因為沒有注意到輸出是要保留一位小數,錯了。

#include<iostream>
#include<string.h>
using namespace std;
int main() {
	int k,n;
	double cof[1005],An;
	while (cin >> k) {
		memset(cof, 0, sizeof(cof)); 
		for (int i = 0 ; i < k; i++) {
			cin >> n >> An;
			cof[n] += An;
		}
		cin >> k;
		for (int i = 0; i < k; i++) {
			cin >> n >> An;
			cof[n] += An;
		}
		 n = 0;//這裡的n初始化放在迴圈裡就錯了...不太懂
		for (int i = 0 ; i <=1000; i++) {
			if (cof[i] !=0) n++;//記錄n個多項式
		}
		cout << n;
		for (int i =1000; i >=0; i--) {
			if (cof[i] != 0)
				printf(" %d %.1lf",i, cof[i]);
		}
		cout << endl;
	}
	return 0;
}