1. 程式人生 > >POJ 3104 二分 坑

POJ 3104 二分 坑

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

晾衣服:n件衣服各含a_i水分,自然幹一分鐘一單位,放烘乾機一分鐘k單位,一次只能晒一件。求最短時間。(在用烘乾機的時候是沒有蒸發這一部分水分的!!!!表示自己已經入坑)

然後二分列舉時間:

時間從1--max(a[i])之間列舉時間,如果是時間大於當前的a[i],就是說明該衣服完全可以自己蒸發幹,那就不需要放入乾燥機裡,然後剩下的就是處理水分大於列舉的這個mid了,然後就是兩個細節!!

①每分鐘烘乾k單位的水,於是我就想當然地除k向上取整了((a_i – mid) / k)。其實應該除以k-1,列個詳細的算式:

設需要用x分鐘的機器,那麼自然風乾需要mid – x分鐘,x和mid需要滿足:

k*x + (mid – x) >= a_i,即 x >= (a_i – mid) / (k – 1)。

②當k=1的時候,很顯然會發生除零錯誤,需要特殊處理。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include<set>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
const int N=1e6+400;
int n;
ll k;
ll a[N];
bool cut(ll l){
    ll temp=0;
    rep(i,1,n)
    if(a[i]>l) temp+=ceil((a[i]-l)*1.0/(k-1));//表示相除的結果需要相除的結果需要取整
                                                //使用ceil函式。ceil(x)返回的是大於x的最小整數。
    return temp<=l;
}
int main(){
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    scanf("%d",&n);
    ll r=0,l=0;
    rep(i,1,n)
    scanf("%lld",&a[i]),r=max(a[i],r);
    scanf("%lld",&k);
    if(k==1) {printf("%lld\n",r);return 0;}
    ll ans=0;
        while(r-l>1){
        ll mid=(l+r)/2;
        if(cut(mid))
        r=mid;
        else
        l=mid;
    }
    printf("%lld\n",r);

    return 0;
}