1. 程式人生 > >POJ 3104 Drying(二分+計數)

POJ 3104 Drying(二分+計數)

題目傳送門

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

題意:輸入n代表的是n件衣服,接下來輸入的n個數代表的是沒一件衣服所帶的含水量,最後一個k代表的是吹風機每分鐘能夠烘乾的水量,自然風乾每分鐘風乾1單位的水。問最少需要幾分鐘才能將所有衣服烘乾。

題解:

對時間進行二分,如果可以在t時間風乾,那就繼續找更小的,否則找更大的。  難點就在於怎麼判斷是否可以在t時間內風乾。  首先對於Ai小於t的衣服,可以直接自然風乾,不需要吹風機,所以不用考慮。

我們假設第i件衣服需要 X 分鐘吹風機的時間,Y分鐘自然風乾的時間,已知總時間 t ,衣服的水量Ai , 吹風機每分鐘減少k單位水, 自然風乾每分鐘減少1單位水。有:

X + Y = t  X * k + Y >= Ai

由這兩個式子可得:X>=(Ai-t)/(k-1)。  有了這個式子就可以計算出所有衣服需要使用吹風機的最小時間,把這些時間相加,如果這個時間小於t就說明可以在t時間內吹乾所有衣服。

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
#define ll long long
ll maxn;
ll n,k;
ll inf=100007;
ll a[100007];
bool solve(ll t)
{
    ll ans=0;
    for(ll i=1;i<=n;i++)
    {
        if(a[i]>t)
        {
            ans+=(a[i]-t)/(k-1);//每件衣服使用吹風機的時間
            if((a[i]-t)%(k-1))
                ans++;
        }
    }
    if(ans<=t)//如果時間小於t
        return true;
    return false;
}
void search_quick()
{
    ll ans=0;
    ll l=1,r=maxn;//mid表示所有衣服晒乾的總時間,二分遍歷尋找最短時間
    while(l<=r)
    {
        ll mid=(l+r)/2;
        if(solve(mid))
        {
            ans=mid;
            r=mid-1;
        }
        else
        {
            l=mid+1;
        }
    }
    printf("%lld\n",ans);
}
int main()
{
    while(~scanf("%lld",&n))
    {
        for(ll i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            maxn=max(maxn,a[i]);
        }
        scanf("%lld",&k);
        if(k==1)//吹風機時間為1,和風乾時間一樣,所以直接輸出最大值就ok了
        {
            printf("%lld\n",maxn);
        }
        else
        {
           search_quick();
        }
    }
    return 0;
}