1. 程式人生 > >A+B for Input-Output Practice (V) --JAVA

A+B for Input-Output Practice (V) --JAVA

題目:

Your task is to calculate the sum of some integers. 

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

Sample Input

2
4 1 2 3 4
5 1 2 3 4 5

Sample Output

10
15

題意:

給你一個數字n,代表有n組測試資料,後跟n行,每一行第一個數字是嗎,代表後面有m個數字,讓你求出來這m個數字的和;

程式碼如下:

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
	Scanner input=new Scanner(System.in);
	int n,m,a,s;
	n=input.nextInt();
	while(true) {
		if(n==0)
			break;
		n--;
		m=input.nextInt();
		s=0;
		for(int i=0;i<m;i++) {
			a=input.nextInt();
			s=s+a;
		}
		System.out.println(s);
	}
}
}