1. 程式人生 > >Sum Problem --JAVA

Sum Problem --JAVA

題目:

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).  In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n. 

Input

The input will consist of a series of integers n, one integer per line. 

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer. 

Sample Input

1
100

Sample Output

1

5050

題意:

給你一個數字n,求出1到n的和,

注意格式,每個結果後面有一個空行。

程式碼如下:

JAVA:

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
	Scanner input=new Scanner(System.in);
	int n,a,s;
	while(input.hasNext()) {
		n=input.nextInt();
		s=0;
		for(int i=1;i<=n;i++) {
			s+=i;
		}
		System.out.println(s);
		System.out.println();
	}
}
}

C++:

#include<stdio.h>
int main()
{
    int i,n;
    while(~scanf("%d",&n))
    {
        int sum=0;
        for(i=0;i<=n;i++)
        {
            sum=sum+i;
        }
        printf("%d\n",sum);
        printf("\n");
    }
    return 0;
}