1. 程式人生 > >Fence Repair(哈夫曼樹+優先佇列)

Fence Repair(哈夫曼樹+優先佇列)

D - Fence Repair Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u Submit

Status

Practice

POJ 3253 use MathJax to parse formulas Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks Lines 2… N+1: Each line contains a single integer describing the length of a needed plank Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts Sample Input

3 8 5 8 Sample Output

34 Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

題意是說鋸木頭,鋸多長的木頭就要收多少的錢。給出木頭的塊數和長度,求最小的花費。

哈夫曼樹: 哈夫曼樹的節點帶權值,並且所有權值之和最小。

假設有n個權值,則構造出的哈夫曼樹有n個葉子結點.n個權值分別設為 w1、w2、…、wn,則哈夫曼樹的構造規則為: (1) 將w1、w2、…,wn看成是有n 棵樹的森林(每棵樹僅有一個結點); (2) 在森林中選出兩個根結點的權值最小的樹合併,作為一棵新樹的左、右子樹,且新樹的根結點權值為其左、右子樹根結點權值之和; (3)從森林中刪除選取的兩棵樹,並將新樹加入森林;

(4)重複(2)、(3)步,直到森林中只剩一棵樹為止

舉例

知字元A B C D E F的權值為8 12 5 20 4 11

先排序,選取最小的兩個節點後出隊,構造成根節點,壓入佇列

再選取最小的兩個節點形成根節點壓入佇列,以此類推

在本題中,一個大木頭切成兩個小木頭,則兩塊小木頭的長度就是切開大木頭的花費,即:每塊小木頭就是一個節點,他的長度就是節點的權值。由於哈夫曼樹節點有權值,且權值之和(樹的帶權路徑長度)最小,那麼只要將小木塊當作節點構造哈夫曼樹,最後的根節點的權值便是最小花費。

程式碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <map>
#include <cstdlib>
#include <algorithm>
#include <queue>
#define ll long long
using namespace std;
int main()
{
    priority_queue <ll ,vector<ll> ,greater<ll> > q;
    ll n,a,b;
    ios::sync_with_stdio(false);
    cin>>n;
    for(ll i=0;i<n;i++)
    {
        cin>>a;
        q.push(a);
    }
    ll ans=0;
    while(q.size()>1)
    {
        a=q.top();
        q.pop();
        b=q.top();
        q.pop();
        q.push(a+b);
        ans+=a+b;
    }
    while(q.empty()==0)
        q.pop();
    cout<<ans<<endl;
    return 0;
}