1. 程式人生 > >7-43 Shuffling Machine (20 分)

7-43 Shuffling Machine (20 分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

 Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

 思路:看不懂沒關係 能理解題目裡的例子就可以了 需要兩個陣列 一個數組用來存放從S1到J2 按順序放好的  另一個數組用來存放洗牌後的陣列  由於數組裡不能存放下S1這種字串 所以還要用兩個陣列儲存數字   另外還需要一個儲存順序的陣列 所以一共是5個數組

#include <stdio.h>
int main(){
        int k;
        scanf("%d",&k);
        int a[54];
        int b[54];
        int c[54];
        for(int i = 0;i < 54;i ++){
            scanf("%d",&a[i]);
        }
        char card1[54];
        char card2[54];
        //卡牌初始化
        for(int i = 0;i < 54;i ++){
            if(i >=0 && i<=12){
                card1[i] = 'S';
                b[i] = i + 1;
            }
            if(i >=13 && i<=25){
                card1[i] = 'H';
                b[i] = i - 12;
            }
            if(i >=26 && i<=38){
                card1[i] = 'C';
                b[i] = i - 25;
            }
            if(i >=39 && i<=51){
                card1[i] = 'D';
                b[i] = i - 38;
            }
            if(i >=52 && i<=53){
                card1[i] = 'J';
                b[i] = i - 51;
            }
        }
        //改變位置後存入新的陣列
        for(int j = 0;j < k;j ++){
            for(int i = 0;i < 54;i ++){
                c[a[i] - 1] = b[i];
                card2[a[i] - 1] = card1[i];
            }
            //重複使用陣列
            for(int x = 0;x < 54;x ++){
                b[x] = c[x];
                card1[x] = card2[x];
            }
        }
        //遍歷陣列後輸出
        for(int i = 0;i < 54;i ++){
            if(i == 53){
                printf("%c%d",card1[i],b[i]);
            }
            else {printf("%c%d ",card1[i],b[i]);
            }
        }
    return 0;
}