1. 程式人生 > >HDU 5867.Water problem【打表】【8月20】

HDU 5867.Water problem【打表】【8月20】

Water problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 233    Accepted Submission(s): 158


Problem Description If the numbers 1 to 5 are written out in words: one, two, three, four, five, then there are 3+3+5+4+4=19 letters used in total.If all the numbers from 1 to n (up to one thousand) inclusive were written out in words, how many letters would be used?

Do not count spaces or hyphens. For example, 342 (three hundred and forty-two) contains 23 letters and 115 (one hundred and fifteen) contains 20 letters. The use of "and" when writing out numbers is in compliance with British usage.

Input There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases.

For each test case: There is one positive integer not greater one thousand.

Output For each case, print the number of letters would be used.
Sample Input 3 1 2 3
Sample Output 3 6 11 題意:1~n英文表示一共用了多少字母(不算-和空格)

思路:打表,O(1)查詢

#include<iostream>
#include<cstdio>
using namespace std;
int ty[10]={0,0,6,6,5,5,5,7,6,6};
int fnum[10]={3,3,3,5,4,4,3,5,5,4};
int en[10]={3,6,6,8,8,7,7,9,8,8};
int num[1005]={0}, sum[1005]={0};
int main()
{
    num[0] = 0;
    for(int i = 1;i < 1005; ++i)
    {
        int n = i;
        if(n >= 1000)
        {
            num[i] += (fnum[n/1000]+8);
            n %= 1000;
        }
        if(n >= 100)
        {
            if(num[i]) num[i] += 3;
            num[i] += (fnum[n/100]+7);
            n %= 100;
        }
        bool flag = false;
        if(n >= 10)
        {
            flag = true;
            if(num[i]) num[i] += 3;
            if(n < 20)
            {
                num[i] += en[n%10];
                sum[i] = sum[i-1]+num[i];
                continue;
            }
            else
            {
                num[i] += ty[n/10];
                n %= 10;
            }
        }
        if(n)
        {
            if(num[i] && !flag) num[i] += 3;
            num[i] += fnum[n];
        }
        sum[i] = sum[i-1]+num[i];
    }
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int N;
        scanf("%d", &N);
        cout << sum[N] << endl;
    }
    return 0;
}