1. 程式人生 > >HDU 1520.Anniversary party【樹型DP】【8月15】

HDU 1520.Anniversary party【樹型DP】【8月15】

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9204    Accepted Submission(s): 3952


Problem Description There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
Output Output should contain the maximal sum of guests' ratings.
Sample Input 7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
Sample Output 5

題意:員工跟領導參加party,每個人都有一個快樂值,當領導去的時候,屬於他的員工就不去;領導不去的時候,他的員工可去可不去。求最大快樂只

思路:樹型DP。ans[i][0]表示i不去,ans[i][1]表示i去。則ans[i][0] = max(他的員工去的快樂值, 他的員工不去的快樂值),ans[i][1] = 他的員工不去+他的快樂值。

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
using namespace std;
const int MAX = 6005;
int N;
vector <int> v[MAX];
int fa[MAX], ha[MAX], a, b, root, ans[MAX][2];
int fi(int root)
{
    if(fa[root] == root) return root;
    else fa[root] = fi(fa[root]);
}
void DFS(int root)
{
    ans[root][1] = ha[root];
    for(vector<int>::iterator it = v[root].begin(); it != v[root].end(); ++it)
    {
        DFS(*it);
        ans[root][0] += max(ans[*it][1], ans[*it][0]);
        ans[root][1] += ans[*it][0];
    }
}
int main()
{
    while(scanf("%d", &N) != EOF)
    {
        memset(ha, 0, sizeof(ha));
        memset(ans, 0, sizeof(ans));
        for(int i = 1; i <= N; ++i)
        {
            fa[i] = i;
            v[i].clear();
            scanf("%d", &ha[i]);
        }
        while(scanf("%d %d", &a, &b) != EOF && a && b)
        {
            v[b].push_back(a);
            fa[a] = fi(b);
        }
        root = fi(1);
        DFS(root);
        cout << max(ans[root][0], ans[root][1]) << endl;
    }
    return 0;
}