1. 程式人生 > >Newcoder 18 D.Aria(next_permutation)

Newcoder 18 D.Aria(next_permutation)

Description

A r i a Aria 是一名武偵高強襲科的學生,由於懸殊的實力差距,沒有人可以與她配合。所以正如她的名字一樣( a

r i a aria 在歌劇中有獨唱曲之意), A r i a
Aria
一直都是孤身一人。

A r i a Aria 在無聊的時候會玩一種特殊的加法遊戲,這個遊戲是這樣的:

1.給出 n

n 個數 a i a_i ,起初 s u m = 0 sum=0

2.把這 n n 個數按 1 1 ~ n n 的順序依次加入,即在第 i i 步時 s u m = s u m + a i sum=sum+a_i

3.每加入一個數後,可以把 s u m sum 十進位制按位拆開後隨意重排,得到一個新的數。重排允許前導 0 0 的出現,比如 10 10 可以重排成 1 1 10 10

但一直玩這個遊戲只會覺得越來越無聊,所以 A r i a Aria 想知道最後能得到的最大的 s u m sum 是多少。

Input

第一行,一個正整數 n n

第二行, n n 個正整數 a i a_i

( n 5 , 1 a i 100 ) (n\le 5,1\le a_i\le 100)

Output

一行,一個正整數,即最大的 s u m sum

Sample Input

5
42 1 3 3 6

Sample Output

100

Solution

每次加一個數之後直接暴力列舉所有重排情況更新最優解即可

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
int n,a[6],ans=0;
void dfs(int pos,int now)
{
	if(pos>n)
	{
		ans=max(ans,now);
		return ;
	}
	now+=a[pos];
	int m=0,b[20],c[20];
	while(now)b[m++]=now%10,now/=10;
	for(int i=0;i<m;i++)c[i]=i;
	do
	{
		int temp=0;
		for(int i=0;i<m;i++)temp=10*temp+b[c[i]];
		dfs(pos+1,temp);
	}while(next_permutation(c,c+m));
}
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)scanf("%d",&a[i]);
	dfs(1,0);
	printf("%d\n",ans);
	return 0;
}