1. 程式人生 > >RXD and math (hdu 6063) 2017多校第三場

RXD and math (hdu 6063) 2017多校第三場

RXD and math
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 310    Accepted Submission(s): 160


Problem Description
RXD is a good mathematician.
One day he wants to calculate:

output the answer module .


 are different prime numbers
 

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers .
 

Output
For each test case, output "Case #x: y", which means the test case number and the answer.
 

Sample Input
10 10
 

Sample Output
Case #1: 999999937
 

Source
2017 Multi-University Training Contest - Team 3

首先看出來u()函式是莫比烏斯函式

然後手動打表找出來的規律,發現結果為n的k次方

利用快速冪直接求就可以了

#include<cstdio>
#include<iostream>
using namespace std;
const long long int mod=1e9+7;
long long int fast_pow_mod(long long int a,long long int b)
{
  long long int res=1;
  while(b)
  {
    if(b&1) res=res*a%mod;
    a=((a%mod)*(a%mod))%mod;
    b>>=1;
  }
  return res;
}
int main()
{
  long long int n,k;
  long long int cas=1;
  while(scanf("%lld%lld",&n,&k)!=EOF)
  {
  long long int w;
  w=fast_pow_mod(n,k);
  printf("Case #%lld: %lld\n",cas++,w%mod);
  }
  return 0;
}

不是數學方面的,直接從網上撈了個快速冪模板發現wa了一次,後來自己寫了一遍,發現是爆long long 了,過程中也要mod