1. 程式人生 > >poj2955——Brackets(區間dp)

poj2955——Brackets(區間dp)

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end
Sample Output

6
6
4
0
6

設dp[i][j]為區間i~j的最大能匹配數量。先初始化,看相鄰兩個能否匹配,接著隔一個匹配,隔兩個匹配。。。之後的匹配要選擇是否比兩個子區間相連的數量更大

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define MAXN 105
using namespace std;
char s[MAXN];
int dp[MAXN][MAXN];
bool check(int a,int b)
{
    if((a=='['&&b==']')||(a=='('&&b==')'))
        return true;
    return false;
}
int main()
{
    int i,j,k,len;
    while(gets(s))
    {
        memset(dp,0,sizeof(dp));
        if(s[0]=='e')
            break;
        len=strlen(s);
        for(i=0; i<len; ++i)
        {
            if(check(s[i],s[i+1]))
                dp[i][i+1]=2;
            else
                dp[i][i+1]=0;
        }
        for(int gap=3; gap<=len; ++gap)
            for(i=0; i+gap-1<len; ++i)
            {
                j=i+gap-1;
                if(check(s[i],s[j]))
                    dp[i][j]=dp[i+1][j-1]+2;
                for(k=i; k<j; ++k)
                    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
            }
        cout<<dp[0][len-1]<<endl;
    }
    return 0;
}