1. 程式人生 > >HDOJ 題目2709Sumsets(遞推)

HDOJ 題目2709Sumsets(遞推)

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1460    Accepted Submission(s): 574


Problem Description Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
Input A single line with a single integer, N.
Output The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
Sample Input 7
Sample Output 6
Source
Recommend teddy   |   We have carefully selected several similar problems for you:  
2544
 2717 2715 2159 1114 


思路:本打算用母函式做的,結果果然超時了,,而且還是先打的表,不會做就網上搜了一下,發現這麼做的,,,(打死我也想不出來啊)

遞推.

一、當n為奇數時,a[n]=a[n-1];

二、當n為偶數時有兩種情況:

1、n=n-2+1+1;

2、n=n/2*2;

所以:a[n]=a[n-2]+a[n/2];

ac程式碼

#include<stdio.h>
int a[1000010];
void fun()
{
	int i;
	a[1]=1;
	a[2]=2;
	for(i=3;i<=1000010;i++)
	{
		if(i&1)
			a[i]=a[i-1]%1000000000;
		else
			a[i]=(a[i-2]+a[i/2])%1000000000;
	}
}
int main()
{
	int n;
	fun();
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",a[n]);
	}
}