1. 程式人生 > >HDU-1217 Arbitrage (有向圖最大環[Floyd])

HDU-1217 Arbitrage (有向圖最大環[Floyd])

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 

Output For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 

Sample Input 3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
Sample Output Case 1: Yes Case 2: No

題目大意:給定n中貨幣,再給出m種關係表示貨幣a對貨幣b的匯率,求貨幣1經過兌換後是否比原本的貨幣1多。

大致思路:本題是看的hdu最小環的題目推薦的,所以很容易就像到了最小環的求法,不過本題是有向圖,而且求最大環,將加法換成乘法,floyd不變即可,因為有向圖的環可以由2個點構成,複雜度為:O(n^2),又本題只求貨幣1為起點的最小環,所以可以用SPFA更快的求得結果

不過感覺有點奇怪,在floyd前賦rate[1][1]=1就會WA,這個應該不影響最終結果吧,已經排除了存在自環(1,1)這種可能,實在想不到還有什麼不符合的

#include <iostream>
#include <cstring>
#include <string>
#include <map>
#include <algorithm>

using namespace std;

int n,m;
double rate[35][35];
map<string,int> mp;

void floyd() {
    for(int k=1;k<=n;++k)
        for(int i=1;i<=n;++i)
            for(int j=1;j<=n;++j)
                rate[i][j]=max(rate[i][j],rate[i][k]*rate[k][j]);//更新貨幣i到貨幣j的最大匯率
}

int main() {
    int kase=0;
    double rat;
    string curr,nxt;
    while(cin>>n,n!=0) {
        for(int i=1;i<=n;++i) {
            cin>>curr;
            mp[curr]=i;
        }
        memset(rate,0,sizeof(rate));
        cin>>m;
        while(m-->0) {
            cin>>curr>>rat>>nxt;
            rate[mp[curr]][mp[nxt]]=rat;
        }
        floyd();
        cout<<"Case "<<++kase<<": ";
        if(rate[1][1]-1.0>0.000001)
            cout<<"Yes\n";
        else
            cout<<"No\n";
    }
    return 0;
}