1. 程式人生 > >Minimum Inversion Number (單點更新 線段樹 )

Minimum Inversion Number (單點更新 線段樹 )

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19112    Accepted Submission(s): 11525


Problem Description The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output For each case, output the minimum inversion number on a single line.

Sample Input 10 1 3 6 9 0 8 5 7 4 2
Sample Output 16
Author

    總共有N個數,如何判斷第i+1個數到最後一個數之間有多少個數小於第i個數呢?不妨假設有一個區間 [1,N],只需要判斷區間[i+1,N]之間有多少個數小於第i個數。如果我們把總區間初始化為0,然後把第i個數之前出現過的數都在相應的區間把它的值定為1,那麼問題就轉換成了[i+1,N]值的總和。再仔細想一下,區間[1,i]的值+區間[i+1,N]的值=區間[1,N]的值(i已經標記為1),所以區間[i+1,N]值的總和等於N-[1,i]的值!因為總共有N個數,不是比它小就是比它(大或等於)。

        現在問題已經轉化成了區間問題,列舉每個數,然後查詢這個數前面的區間值的總和,i-[1,i]既為逆序數。

        線段樹預處理時間複雜度O(NlogN),N次查詢和N次插入的時間複雜度都為O(NlogN),總的時間複雜度O(3*NlogN)

/*num陣列 是把記錄 數是否存在 存在即為1。
總共有N個數,如何判斷第i+1個數到最後一個
數之間有多少個數小於第i個數呢?不妨假設
有一個區間 [1,N],只需要判斷區間[i+1,N]之
間有多少個數小於第i個數。如果我們把總區間初
始化為0,然後把第i個數之前出現過的數都在相應
的區間把它的值定為1,那麼問題就轉換成了[i+1,N]
值的總和
*/
#include <stdio.h>
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
#define size 5005
#define min(a, b) a > b ? b : a
int num[size << 2], x[size];
void pushup(int rt)
{
    num[rt] = num[rt << 1] + num[rt << 1 | 1];
}
void build( int l, int r, int rt)
{
    num[rt] = 0;
    if( l == r) return;
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
}

int qurey( int L, int R, int l, int r, int rt)
{
    if( L <= l && r <= R)
        return num[rt];
    int m = (l + r) >> 1;
    int ans = 0;
    if(L <= m) ans+=qurey(L, R, lson);
    if(R > m) ans+=qurey(L, R, rson);
    return ans;
}
void updata( int p, int l, int r, int rt)
{
    if( l == r)
    {
        num[rt]++;return;
    }
    int m = ( l + r) >> 1;
    if( p <= m) updata(p, lson);
    else updata(p, rson);
    pushup(rt);
}
int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        int sum = 0;
        build(0, n - 1, 1);
        for( int i= 1; i <= n; i++)
        {
            scanf("%d", &x[i]);
            sum += qurey(x[i], n - 1, 0, n - 1, 1);
            updata(x[i], 0, n - 1, 1);

        }
        int tmp = sum;
        for( int i = 1; i <= n; i++)
        {
            sum += n - x[i] - x[i] - 1;
            tmp = min(tmp, sum);
        }
         printf("%d\n",tmp);
    }
    return 0;
}