1. 程式人生 > >HDOJ 題目1709 The Balance(母函式)

HDOJ 題目1709 The Balance(母函式)

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5756    Accepted Submission(s): 2338


Problem Description Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.

Input The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.

Output For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.

Sample Input 3 1 2 4 3 9 2 1
Sample Output 0 2 4 5
Source
Recommend lcy   |   We have carefully selected several similar problems for you:  
1721
 1710 1707 1792 1714  思路:題意:
給出一些砝碼,可以放在天秤的兩邊,問有[1,sum]中有哪些重量是不可稱出來的
題解:
母函式,這裡比較特殊的一點是砝碼可以放在天枰的左右兩端,我們可以在c2[j+k]+=c1[j]
後加多一句c2[abs(j-k)]+=c[j]...即可,假設原來的砝碼都放在右端,則可以把新加的砝碼放在左端,得到新重量。 ac程式碼
#include<stdio.h>
#include<string.h>
#include<math.h>
int c1[100010],c2[100010],a[100010],b[100010];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,j,k,sum=0,c=0,end;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		c1[0]=c1[a[0]]=1;
	//	end=a[0];
		for(i=2;i<=n;i++)
		{
			for(j=0;j<=sum;j++)
			{
				for(k=0;k<=a[i-1]&&k+j<=sum;k+=a[i-1])
				{
					c2[j+k] +=c1[j];
					c2[abs(j-k)] +=c1[j];
				}
			}
			//end+=a[i-1];
			for(j=0;j<=sum;j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		for(i=0;i<=sum;i++)
		{
			if(c1[i]==0)
			{
				b[c++]=i;
			}
		}
		if(!c)
		{
			printf("0\n");
			continue;
		}
		printf("%d\n",c);
		for(i=0;i<c;i++)
		{
			if(!i)
				printf("%d",b[i]);
			else
				printf(" %d",b[i]);
		}
		printf("\n");
	}
}