1. 程式人生 > >HDU 1023 Train Problem II (卡特蘭數)

HDU 1023 Train Problem II (卡特蘭數)

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11019    Accepted Submission(s): 5836


 

Problem Description

As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

Input

The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

Output

For each test case, you should output how many ways that all the trains can get out of the railway.

Sample Input

1

2

3

10

Sample Output

1

2

5

16796

Hint

The result will be very large, so you may not process it by 32-bit integers.

Author

Ignatius.L

求前100位的卡特蘭數=-=  

卡特蘭數有一個遞推公式  C(n)=C(n-1)*(4*n-2)/(n+1) 又因為到100位 所以需要用大數 

由公式可以看出 先用大數乘法 再用大數除法 

需要先乘完再除  不然前幾位 因為會取整會變成0

ac程式碼

#include <iostream>
#include <stdio.h>
#include <vector>
#include <algorithm>
#include <map>
#include <stdlib.h>
#include <string.h>
#include <sstream>
#include <math.h>
#include <queue>
using namespace std;
int a[105][105];
int b[105];
void hanshu(int n){
	int digit=b[n-1];
	long long flag=0;
	for(int i=1;i<=b[n-1];i++){
		a[n][i]=a[n-1][i]*(4*n-2)+flag;
		if(a[n][i]/10){
			flag=a[n][i]/10;
			a[n][i]%=10;
		}
		else flag=0;
	}
	digit++;
	while(flag/10){
		a[n][digit]=flag%10;
		flag/=10;
		digit++;
	}
	if(flag){
		a[n][digit]=flag;
		digit++;
	}
	digit--;
	flag=0;
	int temp;
	for(int i=digit;i>=1;i--){
		temp=a[n][i]+flag*10;
		a[n][i]=temp/(n+1);
		flag=temp%(n+1);
	}
	for(int i=digit;i>=1;i--){
		if(a[n][i]==0){
			digit--;
		}
		else break;
	}
	b[n]=digit;
}
void output(int n){
	for(int i=b[n];i>=1;i--){
		cout<<a[n][i];
	}
	cout<<endl;
}
int main()
{
	a[1][1]=1;
	b[1]=1;
	for(int i=2;i<=100;i++){
		hanshu(i);
	}
	int n;
	while(~scanf("%d",&n)){
		output(n);
	}
}