1. 程式人生 > >HDU1969:Pie(二分 + 貪心)

HDU1969:Pie(二分 + 貪心)

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10919    Accepted Submission(s): 3894


Problem Description My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input 3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
Sample Output 25.1327 3.1416 50.2655
Source 題意:N種蛋糕,每個半徑給出,要分給F+1個人,要求每個人分的體積一樣(形狀可以不一樣),而且每人只能分得一種蛋糕(不能多種蛋糕拼在一起),求每人最大可以分到的體積。

思路:初始下界為0,上界為最大的蛋糕體積,二分求出結果。

# include <stdio.h>
# include <math.h>
# include <algorithm>
# define pi acos(-1.0)
using namespace std;
double a[10001];
int n, f;
bool cmp(double a, double b) {return a>b;}
bool fun(double s)
{
    int cnt = 0, tmp;
    for(int i=0; i<n; ++i)
    {
        tmp = (int)(a[i]/s);
        if(tmp == 0 || cnt >= f)
            break;
        cnt += tmp;
    }
    return cnt<f?false:true;
}
int main()
{
    int t;
    double l, r, mid;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&f);
        ++f;
        for(int i=0; i<n; ++i)
        {
            scanf("%lf",&a[i]);
            a[i] = pi*a[i]*a[i];
        }
        sort(a, a+n, cmp);
        l = 0;
        r = a[0];
        mid = (l+r)/2;
        while(r-l>1e-5)
        {
            if(fun(mid))
                l = mid;
            else
                r = mid;
            mid = (l+r)/2;
        }
        printf("%.4f\n",mid);

    }
    return 0;
}