1. 程式人生 > >Space Elevator(多重揹包)

Space Elevator(多重揹包)

Problem Description The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.
Input * Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.
Output * Line 1: A single integer H, the maximum height of a tower that can be built
Sample Input 3 7 40 3 5 23 8 2 52 6
Sample Output 48
/*題意:有一群牛要上太空,他們計劃建一個太空梯(用一些石頭壘),他們有k種不同型別的石頭,每一種石頭的高度
為h,數量為c,由於會受到太空輻射,每一種石頭不能超過這種石頭的最大建造高度a,求解利用這些石頭所能修建的
太空梯的最高的高度.多重揹包問題,與一般的多重揹包問題所不同的知識多了一個限制條件就是某些"物品"疊加
起來的"高度"不能超過一個值,於是我們可以對他們的最高可能達到高度進行排序,然後就是一般的多重揹包問題了
*/
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int dp[60000],k[60000];
struct node
{
    int h,c,a;
}m[60000];
int n;
int cmp(node x,node y)
{
    return x.a<y.a;
}
int main()
{
   while(cin>>n)
   {

       for(int i=1;i<=n;i++)
       {
           cin>>m[i].h>>m[i].a>>m[i].c;
       }
       sort(m+1,m+n+1,cmp);
       memset(dp,0,sizeof(dp));
       dp[0]=1;
       int ans=0;
       for(int i=1;i<=n;i++)
        {
            memset(k,0,sizeof(k));
           for(int j=m[i].h;j<=m[i].a;j++)
           {
               if(!dp[j]&&dp[j-m[i].h]&&m[i].c>k[j-m[i].h])
               {
                   dp[j]=1;
                   k[j]=k[j-m[i].h]+1;
                   if(j>ans)ans=j;
               }
           }
        }
        cout<<ans<<endl;
   }
   return 0;
}