1. 程式人生 > >River Hopscotch poj3258 (二分+貪心思想+最小值最大化)

River Hopscotch poj3258 (二分+貪心思想+最小值最大化)

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12390 Accepted: 5306

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end,L

 units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks,N (0 ≤N ≤ 50,000) more rocks appear, each at an integral distanceDi from the start (0 <Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up toM

rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance*before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set ofM rocks.

Input

Line 1: Three space-separated integers:L,N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removingM rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
/**

貌似和poj3273差不多
不過理解題意有點麻煩
給出L,n個點 其實是n+2個點 包括開始(0)和結束(L)
排序一下
給出m
刪除m個點後 求得最小的倆石頭之間的距離
就是有距離出發點0...dis[i]...L的石頭
問 刪除m個點之後 使得最小距離最大,求出最大值是多少

那麼二分邊界問題
上界就是 L-0 當n=m時成立
下界就是 min(dis[i]-dis[i-1]) 當m=0時成立

詳細問題見下程式碼

**/
#include <algorithm>
#include <iostream>

using namespace std;
const int inf = 1e9;

int dis[50010];

int main()
{
    int L,i;
    int n,m;
    int low,high,cnt,sum;
    while(cin>>L>>n>>m)
    {
        dis[0] = 0;
        low = inf;

        for(i=1; i<=n; i++)
        {
            cin>>dis[i];
        }
        dis[n+1] = L;
        sort(dis,dis+n+1);  ///排序一下 有點貪心思想
        high = L; ///上界
        for(i=1; i<=n+1; i++)
        {
            low = min(low,dis[i]-dis[i-1]);  ///求下界
        }
        while(low < high)
        {
            cnt=0; ///計刪除的點數
            sum=0; ///記錄兩點之間跳躍距離
            int mid = (low+high)>>1;
            for(i=1; i<=n; i++)
            {
                if(sum+dis[i]-dis[i-1] <= mid)  ///距離小於mid 繼續刪除
                {
                    cnt++;                      ///類比3273
                    sum+=(dis[i]-dis[i-1]);     ///如果可以刪除 那麼sum這距離會變大 繼續刪除sum會繼續加
                }
                else
                {
                    sum=0; ///跳躍距離目前為0了
                }
            }
            if(cnt <= m) ///當刪除點m個時也不一定輸出的最小距離最大
            {
                ///所以 繼續進行二分右半邊查詢 找比較大的跳躍距離
                low = mid+1;
            }
            else
            {
                high = mid;
            }
        }
        cout<<low<<endl;
    }
    return 0;
}