1. 程式人生 > >HDU 1074 Doing Homework(經典狀壓dp)

HDU 1074 Doing Homework(經典狀壓dp)

nis cursor ins wan n) int subject nal ane

題目鏈接

Doing Homework Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject‘s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject‘s homework).
Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input

2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3

Sample Output

2 Computer Math English 3 Computer English Math 題意:有N門功課,分別有deadline(最後期限)和cost(做這門作業要花的時間),在ddl後x天交作業就要扣x分,而且不能同時做兩門功課及以上,問怎麽安排順序扣的分最少。 全排列的話就是N!,肯定會TLE。 相對而言N其實很小,那麽可以枚舉每門功課選不選,那麽狀態數最多只有2^15個。這樣就不會tle了。 狀態壓縮DP就是一種用二進制來替代枚舉的過程(雖說我感覺本質還是暴力枚舉 常使用位運算 dp[i|(1<<j)] = max(dp[i|(1<<j)] , dp[i] + sum_cost) 其中sum_cost表示做完這些已選中的科目所需的時間 輸出還有一個打印順序的,就用pre數組來記錄就好了。 代碼如下: 技術分享圖片
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int INF = 0x3f3f3f3f;
const int maxn = 16;
struct Node {
    char name[110];
    int D,C;
} node[maxn];
int dp[1<<maxn], pre[1<<maxn];
int n;

void print_ans(int now) {
    if (!now) return;
    int temp;
    for (int i = 0; i < n; i++) {
        if ((now & (1<<i)) && !(pre[now] & (1<<i))) {
            temp = i;
            break;
        }
    }
    print_ans(pre[now]);
    puts(node[temp].name);
}

int main() {
    int T; scanf("%d", &T);
    while (T--) {
        memset(dp, 0x3f, sizeof(dp));
        memset(pre, 0, sizeof(pre));
        scanf("%d", &n);
        for (int i = 0; i < n; i++) scanf("%s%d%d", node[i].name, &node[i].D, &node[i].C);
        dp[0] = 0;
        for (int i = 0; i < (1 << n); i++) {
            for (int j = 0; j < n; j++) {
                if (i & (1 << j)) continue;
                int s = 0;
                for (int k = 0; k < n; k++)
                    if (i & (1 << k)) s += node[k].C;
                s += node[j].C;
                if (s > node[j].D) s -= node[j].D;
                else s = 0;
                if (dp[i|(1<<j)] > dp[i] + s) {
                    dp[i|(1<<j)] = dp[i] + s;
                    pre[i|(1<<j)] = i;
                }
            }
        }
        printf("%d\n", dp[(1<<n)-1]);
        print_ans((1<<n)-1);
    }
}
View Code

HDU 1074 Doing Homework(經典狀壓dp)