1. 程式人生 > >POJ 2955 Brackets (區間dp 括號匹配)

POJ 2955 Brackets (區間dp 括號匹配)

total con cpp class pre following roc put inpu


Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3951 Accepted: 2078

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s
    ) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im n

, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

Stanford Local 2004

題目鏈接:

id=2955">http://poj.org/problem?

id=2955

題目大意:給一個括號序列,問序列中合法的括號最多有多少個。若A合法。則[A],(A)均合法,若A,B合法則AB也合法

題目分析:和POJ 1141那道經典括號匹配類似,這題更簡單一些。想辦法把問題轉化,既然要求最大的括號匹配數,我們考慮加最少的括號。使得整個序列合法,這樣就轉變成1141那題。開下腦動類比二分圖最大匹配的性質,最大匹配+最大獨立集=點數,顯然要增加最少的點使序列合法,則加的最少的點數即為|最大獨立集|。我們要求的是原序列的|最大匹配|,以上純屬yy,以下給出轉移方程,和1141一模一樣
dp[i][i] = 1;
然後枚舉區間長度
1)外圍匹配:dp[i][j] = dp[i + 1][j - 1];
2)外圍不匹配。枚舉切割點:dp[i][j] = min(dp[i][j], dp[i][k] + dp[k + 1][j]); (i <= k < j)

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const INF = 0x3fffffff;
char s[205];
int dp[205][205];

int main()
{
    while(scanf("%s", s) != EOF && strcmp(s, "end") != 0)
    {
        int len = strlen(s);
        memset(dp, 0, sizeof(dp));
        for(int i = 0; i < len; i++)
            dp[i][i] = 1;
        for(int l = 1; l < len; l++)
        {
            for(int i = 0; i < len - l; i++)
            {
                int j = i + l;
                dp[i][j] = INF;
                if((s[i] == '(' && s[j] == ')') || (s[i] == '[' && s[j] == ']'))
                    dp[i][j] = dp[i + 1][j - 1];
                for(int k = i; k < j; k++)
                    dp[i][j] = min(dp[i][j], dp[i][k] + dp[k + 1][j]);
            }
        }
        printf("%d\n", len - dp[0][len - 1]);
    }
}



POJ 2955 Brackets (區間dp 括號匹配)