1. 程式人生 > >poj2406 Power Strings

poj2406 Power Strings

lib ring concat accept std ont mod long long abcde

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 39658 Accepted: 16530

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01



KMP算法

設字符串的長度為l,假設l%(l-next[l])=0。該序列為循環序列,循環節長度為l-next[l],答案即為l/(l-next[l]);反之則不為循環序列。答案為1。




#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#define F(i,j,n) for(int i=j;i<=n;i++)
#define D(i,j,n) for(int i=j;i>=n;i--)
#define ll long long
#define pa pair<int,int>
#define maxn 1000010
#define inf 1000000000
using namespace std;
char s[maxn];
int l,nxt[maxn];
inline void getnext()
{
	int i=0,j=-1;
	nxt[0]=-1;
	while (i<l)
	{
		if (j==-1||s[i]==s[j]) nxt[++i]=++j;
		else j=nxt[j];
	}
}
int main()
{
	scanf("%s",s);
	while (s[0]!='.')
	{
		l=strlen(s);
		getnext();
		if (l%(l-nxt[l])==0) printf("%d\n",l/(l-nxt[l]));
		else printf("1\n");
		scanf("%s",s);
	}
}


poj2406 Power Strings