1. 程式人生 > >POJ-3522 Slim Span(最小生成樹)

POJ-3522 Slim Span(最小生成樹)

while several oid win pro png zeros nds ber

Slim Span
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8633 Accepted: 4608

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (V, E), where V is a set of vertices {v

1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge eE has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n

− 1 edges of T.

技術分享
Figure 5: A graph G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

技術分享
Figure 6: Examples of the spanning trees of G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n m
a1 b1 w1
?
am bm wm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ mn(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50

Source

Japan 2007 題目大意:條件給你n個點,m條邊,求n-1條邊圖連通的情況下最大邊與最小邊的差的最小值。 解題思路:根據條件先建圖,然後按邊排序,直接枚舉,從第x小的邊開始建樹,(此處需要註意每次從x小的邊開始建立一棵樹後直接x++進行下次簡樹,因為已經按邊排序好了,每次得到的肯定是x情況下差最小的情況),沒有太多技巧,枚舉+建樹就行了。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=105;
int f[10002];
int n,m;
struct Edge
{
    int u,v,w;
};
Edge edge[100000];

bool cmp(Edge a,Edge b)
{
    return a.w<b.w;
}

int Find(int x)
{
    int r = x;
    while(r!=f[r])
    {
        r = f[r];
    }
    while(x!=f[x])
    {
        int j = f[x];
        f[x] = f[r];
        x = j;
    }
    return x;
}

void merge2(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
    {
        f[fy] = fx;
    }
}

int Cal(int x)
{
    int i;
    for(i=1;i<=n;i++)
    {
        f[i] = i;
    }
    int mind=INF,maxd=-1;
    int cnt=0;
    for(i=x;i<m;i++)
    {
        int u=edge[i].u , v=edge[i].v , w=edge[i].w;
        int fu=Find(u),fv=Find(v);
        if(fu!=fv)
        {
            f[fu] = fv;
            cnt++;
            mind = min(mind,w);
            maxd = max(maxd,w);
            merge2(u,v);
        }
        if(cnt==n-1)
            break;
    }
    if(cnt == n-1)
    {
        int ans = maxd-mind;
        return ans;
    }
    return -1;
}

int main()
{
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
        {
            break;
        }
        int i,a,b,w;
        for(i=0;i<m;i++)
        {
            scanf("%d %d %d",&a,&b,&w);
            edge[i].u=a;
            edge[i].v=b;
            edge[i].w=w;
        }
        sort(edge,edge+m,cmp);
        int ans=INF;
        for(i=0;i<m;i++)
        {
            if(m-i<n-1)
            {
                break;
            }
            int d = Cal(i);
            if(d!=-1 && d<ans)
            {
                ans = d;
            }
        }
        if(ans == INF)
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
}

POJ-3522 Slim Span(最小生成樹)