1. 程式人生 > >POJ 2349 Arctic Network(最小生成樹)

POJ 2349 Arctic Network(最小生成樹)

Arctic Network
Time Limit: 2000MS Memory Limit: 65536K

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

題意:有S顆衛星和P個哨所,有衛星的兩個哨所之間可以任意通訊;否則,一個哨所只能和距離它小於等於D的哨所通訊。給出衛星的數量和P個哨所的座標,求D的最小值。

分析:這是一個最小生成樹問題。P個哨所最多用P-1條邊即可連起來,而S顆衛星可以代替S-1條邊,基於貪心思想,代替的邊越長,求得的D就越小。所以可以用一個數組儲存加入最小生成樹的邊的長度,共有P-1條邊,把前S-1條較長的邊代替掉,剩下的邊中最長的即為所求,即d[(P-1) - (S-1) - 1] = d[P-S-1]。

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int father[550], m, k;
double d[550];
struct post
{
    double x, y;
}p[550];
struct edge
{
    int u, v;
    double w;
}e[500005];
bool comp(edge e1, edge e2)
{
    return  e1.w < e2.w;
}
double get_dis(double x1, double y1, double x2, double y2)
{
    return sqrt((x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));
}
void Init(int n)
{
    for(int i = 1; i <= n; i++)
        father[i] = i;
}
int Find(int x)
{
    if(x != father[x])
        father[x] = Find(father[x]);
    return father[x];
}
void Merge(int a, int b)
{
    int p = Find(a);
    int q = Find(b);
    if(p > q)
        father[p] = q;
    else
        father[q] = p;
}
void Kruskal(int n)
{
    k = 0;
    double Max = 0;
    for(int i = 0; i < m; i++)
        if(Find(e[i].u) != Find(e[i].v))
        {
            Merge(e[i].u, e[i].v);
            d[k++] = e[i].w;
            n--;
            if(n == 1)
                return;
        }
}
int main()
{
    int t, S, P, i, j;
    double x, y;
    scanf("%d",&t);
    while(t--)
    {
        m = 0;
        scanf("%d%d",&S,&P);
        Init(P);
        for(i = 1; i <= P; i++)
            scanf("%lf%lf",&p[i].x, &p[i].y);
        for(i = 1; i <= P; i++)
            for(j = i + 1; j <= P; j++)
            {
                e[m].u = i;
                e[m].v = j;
                e[m++].w = get_dis(p[i].x, p[i].y, p[j].x, p[j].y);
                e[m].u = j;
                e[m].v = i;
                e[m++].w = get_dis(p[i].x, p[i].y, p[j].x, p[j].y);
            }
        sort(e, e+m, comp);
        Kruskal(P);
        printf("%.2lf\n",d[P-S-1]);
    }
    return 0;
}