1. 程式人生 > >HDU 1544 Palindromes(回文字符子串)

HDU 1544 Palindromes(回文字符子串)

mar length bre tput for ons 文字 rom pre

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

Now give you a string S, you should count how many palindromes in any consecutive substring of S.

Input
There are several test cases in the input. Each case contains a non-empty string which has no more than 5000 characters.

Proceed to the end of file.
Output
A single line with the number of palindrome substrings for each case.
Sample Input
aba
aa
Sample Output
4
3

題意:

問有多少個回文的子串。

題解:

從子串的長度考慮,長度為奇數的子串:它的中心只能在[1,len-2]範圍內,分別從中心開始向兩邊擴展,遇到不回文就直接停止拓展。長度為偶數的子串:中心對稱的左數範圍在[0,len-2],分別以這中心的兩個數向兩邊擴展。

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
    string s;
    while(cin>>s)
    {
        int ans=0;
        int len=s.length();
        for(int i=1;i<len-1;i++)
        {
            for(int j=1;i-j>=0&&i+j<len;j++)
            {
                if(s[i-j]==s[i+j])
                    ans++;
                else
                    break;
            }
        }
        for(int i=0;i<len-1;i++)
        {
            for(int j=0;i-j>=0&&i+j+1<len;j++)
            {
                if(s[i-j]==s[i+j+1])
                    ans++;
                else
                    break;
            }
        }
        cout<<ans+len<<endl;
    }
    return 0;
}

HDU 1544 Palindromes(回文字符子串)