1. 程式人生 > >poj 2774 Long Long Message(最長公共子串)

poj 2774 Long Long Message(最長公共子串)

Long Long Message
Time Limit: 4000MS Memory Limit: 131072K
Total Submissions: 21724 Accepted: 8918
Case Time Limit: 1000MS

Description

The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother. 

The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon found out: 

1. All characters in messages are lowercase Latin letters, without punctuations and spaces. 
2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long. 
3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer. 
E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc. 
4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different. 

You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat. 

Background: 
The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be. 

Why ask you to write a program? There are four resions: 
1. The little cat is so busy these days with physics lessons; 
2. The little cat wants to keep what he said to his mother seceret; 
3. POJ is such a great Online Judge; 
4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :( 

Input

Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.

Output

A single line with a single integer number – what is the maximum length of the original text written by the little cat.

Sample Input

yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output

27
題意:給定兩個字串A 和B,求最長公共子串。
思路:字串的任何一個子串都是這個字串的某個字尾的字首。求A 和B 的最長公共子串等價於求A 的字尾和B 的字尾的最長公共字首的最大值。如果列舉A和B 的所有的字尾,那麼這樣做顯然效率低下。由於要計算A 的字尾和B 的字尾的最長公共字首,所以先將第二個字串寫在第一個字串後面,中間用一個沒有出現過的字元隔開,再求這個新的字串的字尾陣列。那麼是不是所有的height 值中的最大值就是答案呢?不一定!有可能這兩個字尾是在同一個字串中的, 所以實際上只有當suffix(sa[i-1]) 和suffix(sa[i])不是同一個字串中的兩個字尾時,height[i]才是滿足條件的。而這其中的最大值就是答案。
AC程式碼:
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
#include <queue>
#define ll long long
using namespace std;

const int maxn = 200005;
const int INF = 1e9;

char s[maxn];
int sa[maxn], t[maxn], t2[maxn], c[maxn], n;
int rank[maxn], height[maxn];
void build_sa(int n, int m){
    int i, *x = t, *y = t2;
    for(i = 0; i < m; i++) c[i] = 0;
    for(i = 0; i < n; i++) c[x[i] = s[i]]++;
    for(i = 1; i < m; i++) c[i] += c[i - 1];
    for(i = n - 1; i >= 0; i--) sa[--c[x[i]]] = i;
    for(int k = 1; k <= n; k <<= 1)
    {
        int p = 0;
        for(i = n - k; i < n; i++) y[p++] = i;
        for(i = 0; i < n; i++) if(sa[i] >= k) y[p++] = sa[i] - k;
        for(i = 0; i < m; i++) c[i] = 0;
        for(i = 0; i < n; i++) c[x[y[i]]]++;
        for(i = 1; i < m; i++) c[i] += c[i - 1];
        for(i = n - 1; i >= 0; i--) sa[--c[x[y[i]]]] = y[i];
        swap(x, y);
        p = 1; x[sa[0]] = 0;
        for(i = 1; i < n; i++)
        x[sa[i]] = y[sa[i - 1]] == y[sa[i]] && y[sa[i - 1] + k] == y[sa[i] + k] ? p - 1 : p++;
        if(p >= n) break;
        m = p;
    }
}
void getHeight(){
    int i, j, k = 0;
    for(i = 1; i <= n; i++) rank[sa[i]] = i;
    for(i = 0; i < n; i++)
    {
        if(k) k--;
        j = sa[rank[i] - 1];
        while(s[i + k] == s[j + k]) k++;
        height[rank[i]] = k;
    }
}
int rmq[maxn][20];
void initRMQ(){
    for(int i = 1; i <= n; i++) rmq[i][0] = rmq[i][0] = height[i];
    for(int k = 1; (1 << k) <= n; k++)
    for(int i = 1; i + (1 << k) - 1 <= n; i++)
    {
        rmq[i][k]=min(rmq[i][k-1],rmq[i+(1<<(k-1))][k-1]);
    }
}
int lcp(int a,int b)
{
    a = rank[a], b = rank[b];
    if(a > b) swap(a, b);
    a++;
    int k = log(b - a + 1.0) / log(2.0);
    return min(rmq[a][k], rmq[b - (1 << k) + 1][k]);
}
int main()
{
    char a[maxn], b[maxn];
    while(~scanf("%s", a))
    {
        scanf("%s", b);
        n = 0;
        int lena = strlen(a), lenb = strlen(b);
        for(int i = 0; i < lena; i++) s[n++] = a[i];
        s[n++] = '#';
        for(int i = 0; i < lenb; i++) s[n++] = b[i];
        s[n] = 0;
        build_sa(n + 1, 256);
        getHeight();
        int ans = 0;
        for(int i = 1; i <= n; i++)
        if((sa[i - 1] < lena && sa[i] > lena) || (sa[i - 1] > lena && sa[i] < lena))
        ans = max(ans, height[i]);
        printf("%d\n", ans);
    }
    return 0;
}