1. 程式人生 > >POJ 2533 Longest Ordered Subsequence(最長遞增子序列)

POJ 2533 Longest Ordered Subsequence(最長遞增子序列)

題目:

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

用maxs[i]表示以第i個數結尾的最長遞增子序列的長度。(本來用的是max,結果有命名衝突,就加了s)

這個題目沒什麼大問題,只有一個地方需要注意,如果一個數比前面所以的數都小,那麼下面這個2層的for迴圈是沒有修改maxs的。

所以maxs的初始化應該全部初始化為1。

程式碼:

#include<iostream>
using namespace std;

int list[1000];
int maxs[1000];

int main()
{
	int n;
	cin >> n;
	for (int i = 0; i <
n; i++) { cin >> list[i]; maxs[i] = 1; } for (int i = 1; i < n; i++)for (int j = 0; j < i; j++)
  if (list[j] < list[i] && maxs[i] < maxs[j] + 1)maxs[i] = maxs[j] + 1;
	int m = 0;
	for (int i = 0; i < n; i++)if (m < maxs[i])m = maxs[i];
	cout << m;
	return 0;
}