1. 程式人生 > >Color the ball (樹狀陣列,區間更新,單點查詢)

Color the ball (樹狀陣列,區間更新,單點查詢)

N個氣球排成一排,從左到右依次編號為1,2,3....N.每次給定2個整數a b(a <= b),lele便為騎上他的“小飛鴿"牌電動車從氣球a開始到氣球b依次給每個氣球塗一次顏色。但是N次以後lele已經忘記了第I個氣球已經塗過幾次顏色了,你能幫他算出每個氣球被塗過幾次顏色嗎?

Input

每個測試例項第一行為一個整數N,(N <= 100000).接下來的N行,每行包括2個整數a b(1 <= a <= b <= N)。 
當N = 0,輸入結束。

Output

每個測試例項輸出一行,包括N個整數,第I個數代表第I個氣球總共被塗色的次數。

Sample Input

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

Sample Output

1 1 1
3 2 1

 

#include<iostream>
#include<cstring> 
int N;
using namespace std;
int c[100010];
int lowbit(int x)//求k 
{
	return x&(-x);
}
void Update(int i,int x)
{
	while(i<=N)
	{
		c[i]+=x;
		i+=lowbit(i);
	}
}
int Query(int n)
{
	int sum=0;
	while(n>0)
	{
		sum+=c[n];
		n-=lowbit(n);
	}
	return sum;
}
int main()
{
	int a,b,i,j;
	while(cin>>N&&N)
	{	
	    memset(c,0,sizeof(c));
	    for(i=0;i<N;i++)   
		{
			cin>>a>>b;
			Update(a,1);
			Update(b+1,(-1));  
		}
		for(i=1;i<N;i++)
		cout<<Query(i)<<" ";
		cout<<Query(N)<<endl;
	}
}