1. 程式人生 > >Matrix 二維樹狀陣列 區間修改+單點查詢

Matrix 二維樹狀陣列 區間修改+單點查詢

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

雞凍,模仿著一維樹狀陣列敲出來提交一發AC。這道題挺有意思,修改一個矩陣區間,區間內的數一開始都為0,修改的時候0變為1,1變為0,詢問一個點看它是0還是為1

每次修改讓每個數加一,最後看它的奇偶性就行了,其實不難qwq

#include <iostream>
#include <cstdio>
#include <cstring>
#define lowbit(x) (x & (-x))

using namespace std;
const int N = 1e3 + 3;

int c[N][N];

void Update(int x, int y, int v)
{
    for(int i = x; i > 0; i -= lowbit(i))
        for(int j = y; j > 0; j -= lowbit(j))
            c[i][j] += v;
}
int GetSum(int x, int y)
{
    int sum = 0;
    for(int i = x; i < N; i += lowbit(i))
        for(int j = y; j < N; j += lowbit(j))
            sum += c[i][j];
    return sum;
}
int main()
{
    int x, n, t, x1, y1, x2, y2;
    char s[2];
    scanf("%d", &x);
    for(int k = 1; k <= x; k++)
    {
        memset(c, 0, sizeof(c));
        scanf("%d%d", &n, &t);
        while(t--)
        {
            scanf("%s", s);
            if(s[0] == 'C')
            {
                scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
                Update(x2, y2, 1);
                Update(x1 - 1, y2, -1);
                Update(x2, y1 - 1, -1);
                Update(x1 - 1, y1 - 1, 1);
            }
            else
            {
                scanf("%d%d", &x1, &y1);
                if(GetSum(x1, y1) % 2 == 1)
                    printf("1\n");
                else
                    printf("0\n");
            }
        }
        if(k < x)
            printf("\n");
    }
    return 0;
}