1. 程式人生 > >SDUT-2124_基於鄰接矩陣的廣度優先搜索遍歷

SDUT-2124_基於鄰接矩陣的廣度優先搜索遍歷

優先 amp problem print ++ clu == 連通圖 記錄

數據結構實驗之圖論一:基於鄰接矩陣的廣度優先搜索遍歷

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

給定一個無向連通圖,頂點編號從0到n-1,用廣度優先搜索(BFS)遍歷,輸出從某個頂點出發的遍歷序列。(同一個結點的同層鄰接點,節點編號小的優先遍歷)

Input

輸入第一行為整數n(0< n <100),表示數據的組數。
對於每組數據,第一行是三個整數k,m,t(0<k<100,0<m<(k-1)*k/2,0< t<k),表示有m條邊,k個頂點,t為遍歷的起始頂點。
下面的m行,每行是空格隔開的兩個整數u,v,表示一條連接u,v頂點的無向邊。

Output

輸出有n行,對應n組輸出,每行為用空格隔開的k個整數,對應一組數據,表示BFS的遍歷結果。

Sample Input

1
6 7 0
0 3
0 4
1 4
1 5
2 3
2 4
3 5

Sample Output

0 3 4 2 5 1

Hint

以鄰接矩陣作為存儲結構。

#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>

int s[105][105];
/*利用鄰接矩陣來記錄圖*/
int n,S,num;
/*n節點數量,S開始節點,num記錄的第幾個節點*/
int pre[105];
/*記錄路徑*/

void BFS()
{
    int f[105];
/*記錄點是否被遍歷過*/
    int q[105],front,base;
/*用數組模擬隊列*/
    int u,i;
    memset(f,0,sizeof(f));
    front = base = 0;
    q[base++] = S;
    f[S] = 1;
    while(front!=base)
    {
        u = q[front++];
        pre[num++] = u;
        for(i=0;i<n;i++)
        {
            if(!f[i]&&s[u][i])
            {
                f[i] = 1;
                q[base++] = i;
            }
        }
    }
}

int main()
{
    int t,m,i;
    int u,v;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&S);
        memset(s,0,sizeof(s));
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            s[u][v] = s[v][u] = 1;
        }
        num = 0;
        BFS(S);
        for(i=0;i<num;i++)
            printf("%d%c",pre[i],i==num-1?'\n':' ');
    }
    return 0;
}

SDUT-2124_基於鄰接矩陣的廣度優先搜索遍歷