1. 程式人生 > >ZOJ3261:Connections in Galaxy War(逆向並查集)

ZOJ3261:Connections in Galaxy War(逆向並查集)

Connections in Galaxy War

Time Limit: 3 Seconds      Memory Limit: 32768 KB

題目連結http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3261

Description:

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input:

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0

, p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

"query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2

10 20

1

0 1

5

query 0

query 1

destroy 0 1

query 0

query 1

Sample Output

1

-1

-1

-1

題意:

先進行合併操作,然後進行詢問和分裂操作,詢問操作返回相連值最大的那個點的下標,如果值最大的點有多個,則要下標最小;分裂操作就從a,b中間斷開。

 

題解:

因為並查集只能“並”,不能“裂”,所以直接處理不好處理。

但是如果我們反過來看,每次分裂操作都是一次合併操作,剛好可以用並查集處理。

之後,我們維護下集合中最大的值以及最小座標就行了。

 

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;

typedef long long ll;
const int N = 10005,Q = 50005 ;
int n,m,que;
char s[Q][10];
ll P[N];
struct father{
    int fa,id;
    ll p;
}f[N];
struct query{
    int x,y;
}q[Q];
struct link{
    int p1,p2;
}l[N<<1];
//用很多陣列來儲存... 
int find(int x){
    return f[x].fa==x ? x : f[x].fa=find(f[x].fa);
}
void Union(int x,int y){
    int fx=find(x),fy=find(y);
    f[fx].fa=fy;
    if(f[fx].p>f[fy].p){
        f[fy].p=f[fx].p;
        f[fy].id=f[fx].id;
    }else if(f[fx].p==f[fy].p){
        f[fy].id=min(f[fy].id,f[fx].id);
    }
}
int main(){
    bool flag = false;
    while(~scanf("%d",&n)){
        map <int ,map<int,int> > mp;
        for(int i=0;i<=n;i++) f[i].fa=i,f[i].id=i;
        for(int i=0;i<n;i++) scanf("%lld",&f[i].p),P[i]=f[i].p;
        scanf("%d",&m);
        for(int i=1,tmp1,tmp2;i<=m;i++){
            scanf("%d%d",&tmp1,&tmp2);
            if(tmp1>tmp2) swap(tmp1,tmp2);
            l[i].p1=tmp1;l[i].p2=tmp2;
        }
        scanf("%d",&que);
        for(int i=1,tmp1,tmp2;i<=que;i++){
            scanf("%s",s[i]);
            if(s[i][0]=='d'){
                scanf("%d%d",&tmp1,&tmp2);
                if(tmp1>tmp2) swap(tmp1,tmp2);
                q[i].x=tmp1;q[i].y=tmp2;
                mp[tmp1][tmp2]=1;
            }else scanf("%d",&q[i].x);
        }
        for(int i=1;i<=m;i++){
            int p1=l[i].p1,p2=l[i].p2;
            if(mp[p1][p2]) continue;
            int fx=find(p1),fy=find(p2);
            if(fx==fy) continue;
            Union(p1,p2);
        }
        int ans[Q];int tot=0;
        for(int i=que;i>=1;i--){
            if(s[i][0]=='d') Union(q[i].x,q[i].y);
            else{
                int now = q[i].x;
                int fx=find(now);
                if(f[fx].p<=P[now] ) ans[++tot]=-1;
                else ans[++tot]=f[fx].id;
            }
        }
        if(flag) printf("\n");
        else flag=true ;
        for(int i=tot;i>=1;i--) printf("%d\n",ans[i]);
    }                                          
    return 0;
}