1. 程式人生 > >HDU1068 Girls and Boys【二分圖 最大獨立集】

HDU1068 Girls and Boys【二分圖 最大獨立集】

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13947    Accepted Submission(s): 6564


 

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

 Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

Source

Southeastern Europe 2000

問題連結:HDU1068 Girls and Boys

問題描述:給定數字n,有n個人從0開始編號到n-1,接下去n行,第i行第一個數字為第i個人的編號,(m)表示有m個人與這個人配對,接下去輸入這每個人的編號

解題思路:求最大獨立集,但是這並不是兩個集合,而是一個集合,所以求出最大匹配後需要/2,最大獨立集=N-最大匹配。

AC的C++程式

#include<iostream>
#include<vector>
#include<cstring>

using namespace std;

const int N=100000;

vector<int>g[N];

bool vis[N];
int link[N];

bool find(int x)
{
	for(int i=0;i<g[x].size();i++)
	{
		int y=g[x][i];
		if(!vis[y])
		{
			vis[y]=true;
			if(link[y]==-1||find(link[y]))
			{
				link[y]=x;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
		  g[i].clear();
		for(int i=0;i<n;i++)
		{
			int a,b,num;
			scanf("%d: (%d)",&a,&num);
			while(num--)
			{
				scanf("%d",&b);
				g[a].push_back(b);
			}
		}
		memset(link,-1,sizeof(link));
		int cnt=0;//最大匹配數 
		for(int i=0;i<n;i++)
		{
			memset(vis,false,sizeof(vis));
			if(find(i))
			  cnt++;
		}
		printf("%d\n",n-cnt/2);//最大獨立集 
	}
	return 0;
}