1. 程式人生 > >hdu1394Minimum Inversion Number解題報告---線段樹(單點插值 & 區間逆序數求和)

hdu1394Minimum Inversion Number解題報告---線段樹(單點插值 & 區間逆序數求和)

                              Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25219    Accepted Submission(s): 14878


 

Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10

1 3 6 9 0 8 5 7 4 2

Sample Output

16

題意:

給你一個有0--n-1數字組成的序列,然後進行這樣的操作,每次將最前面一個元素放到最後面去會得到一個序列,那麼這樣就形成了n個序列,那麼每個序列都有一個逆序數,找出其中最小的一個輸出!

                                           線段樹求逆序數:

把樹的葉子節點作為每個數的對應位置
單點插值到第i個數時,我們需要求出前i次插入的數中有多少個比vv[i]大, 
即去尋找已經插入的數中比vv[i]大的數的個數  即查詢葉子節點vv[i]到n的數的個數

把每個vv[i]放到最後的逆序數為sum += n - 1 - 2 * vv[i]。

 AC Code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
using namespace std;
static const int MAX_N = 5005;
int segtree[MAX_N << 2];
int vv[MAX_N];
void PushUp(int rt){
    segtree[rt] = segtree[rt << 1] + segtree[rt << 1 | 1];
}
void build(int l, int r, int rt){   //建樹
    segtree[rt] = 0;
    if(l == r) return;
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
}
void update(int p, int l, int r, int rt){   //單點插值
    if(l == r){
        segtree[rt]++;
        return;
    }
    int m = (l + r) >> 1;
    if(p <= m) update(p, lson);
    else update(p, rson);
    PushUp(rt);
}
int query(int L, int R, int l, int r, int rt){  //區間求和(逆序數)
    if(l >= L && r <= R){
        return segtree[rt];
    }
    int m = (l + r) >> 1;
    int res = 0;
    if(L <= m) res += query(L, R, lson);
    if(R > m) res += query(L, R, rson);
    return res;
}
int main(){
    int n;
    while(scanf("%d", &n) != EOF){
        build(0, n - 1, 1);
        int sum = 0;
        for(int i = 0; i < n; i++){
            scanf("%d", &vv[i]);
            sum += query(vv[i], n - 1, 0, n - 1, 1);
            update(vv[i], 0, n - 1, 1);
        }
        int min_res = sum;
        for(int i = 0; i < n; i++){
            sum += n - 1 - 2 * vv[i];   //0 ---> n - 1 逆序數
            min_res = min(min_res, sum);
        }
        printf("%d\n", min_res);
    }
    return 0;
}