1. 程式人生 > >hdu1754I Hate It解題報告---線段樹(單點替換 & 區間最值)

hdu1754I Hate It解題報告---線段樹(單點替換 & 區間最值)

                                        I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 106690    Accepted Submission(s): 40063

Problem Description

很多學校流行一種比較的習慣。老師們很喜歡詢問,從某某到某某當中,分數最高的是多少。
這讓很多學生很反感。

不管你喜不喜歡,現在需要你做的是,就是按照老師的要求,寫一個程式,模擬老師的詢問。當然,老師有時候需要更新某位同學的成績。

Input

本題目包含多組測試,請處理到檔案結束。
在每個測試的第一行,有兩個正整數 N 和 M ( 0<N<=200000,0<M<5000 ),分別代表學生的數目和操作的數目。
學生ID編號分別從1編到N。
第二行包含N個整數,代表這N個學生的初始成績,其中第i個數代表ID為i的學生的成績。
接下來有M行。每一行有一個字元 C (只取'Q'或'U') ,和兩個正整數A,B。
當C為'Q'的時候,表示這是一條詢問操作,它詢問ID從A到B(包括A,B)的學生當中,成績最高的是多少。
當C為'U'的時候,表示這是一條更新操作,要求把ID為A的學生的成績更改為B。

Output

對於每一次詢問操作,在一行裡面輸出最高成績。

Sample Input

5 6

1 2 3 4 5

Q 1 5

U 3 6

Q 3 4

Q 4 5

U 2 9

Q 1 5

Sample Output

 

5

6

5

9

                              線段樹入門---單點替換 & 區間最值

AC Code: 

#include <cstdio>
#include <cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<map>
#include<queue>
#include<climits>
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
using namespace std;
static const int MAX_N = 2e5 + 5;

int segtree[MAX_N << 2];
void PushUp(int rt){
    segtree[rt] = max(segtree[rt << 1], segtree[rt << 1 | 1]);
}
void build(int l, int r, int rt){   //建樹
    if(l == r){
        scanf("%d", &segtree[rt]);
        return;
    }
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    PushUp(rt);
}
void update(int p, int v, int l, int r, int rt){    //單點替換
    if(l == r){
        segtree[rt] = v;
        return;
    }
    int m = (l + r) >> 1;
    if(p <= m) update(p, v, lson);
    else update(p, v, rson);
    PushUp(rt);
}
int query(int L, int R, int l, int r, int rt){  //區間最值
    if(l >= L && r <= R){
        return segtree[rt];
    }
    int m = (l + r) >> 1;
    int res = -INT_MAX;
    if(L <= m) res = max(res, query(L, R, lson));
    if(R > m) res = max(res, query(L, R, rson));
    return res;
}
int main(){
    int n, q;
    char str[10];
    while(scanf("%d%d", &n, &q) != EOF){
        build(1, n, 1);
        while(q--){
            int a, b;
            scanf("%s%d%d", str, &a, &b);
            switch(str[0]){
                case 'Q' : printf("%d\n", query(a, b, 1, n, 1)); break;
                case 'U' : update(a, b, 1, n, 1); break;
            }
        }
    }
    return 0;
}