1. 程式人生 > >HDU1061 Rightmost Digit(快速冪取餘)

HDU1061 Rightmost Digit(快速冪取餘)

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 68789    Accepted Submission(s): 25687

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2 3 4

Sample Output

7 6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

方法:

此題使用快速冪取餘來解決。

程式碼:

#include <bits/stdc++.h>
using namespace std;

poww(int a, int b, int c)
{
	int ans = 1;
	a = a % c;
	while (b > 0)
	{
		if (b % 2 == 1)
			ans = (ans * a) % c;
		b = b / 2;
		a = (a * a) % c;
	}
	
	return ans;
}

int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		int n;
		cin >> n;
		cout << poww(n, n, 10) << endl;
	}
	
	return 0;
}

關於快速冪取餘的講解,點選此處到達