1. 程式人生 > >PKU 2406:Power Strings 【KMP】

PKU 2406:Power Strings 【KMP】

Power Strings

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 70   Accepted Submission(s) : 27
Problem Description Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output For each s you should print the largest n such that s = a^n for some string a.
Sample Input abcd aaaa ababab .
Sample Output 1 4 3

題意:給一個字串S長度不超過10^6,求最大的n使得S由n個相同的字串a連線而成,如:"ababab"則由n=3個"ab"連線而成,"aaaa"由n=4個"a"連線而成,"abcd"則由n=1個"abcd"連線而成。

定理:假設S的長度為len,則S存在迴圈子串,當且僅當,len可以被len - next[len]整除,最短迴圈子串為S[len - next[len]]

例子證明:
設S=q1

q2q3q4q5q6q7q8,並設next[8] = 6,此時str = S[len - next[len]] = q1q2,由字串特徵向量next的定義可知,q1q2q3q4q5q6 = q3q4q5q6q7q8,即有q1q2=q3q4,q3q4=q5q6,q5q6=q7q8,即q1q2為迴圈子串,且易知為最短迴圈子串。由以上過程可知,若len可以被len - next[len]整除,則S存在迴圈子串,否則不存在。

解法:利用KMP演算法,求字串的特徵向量next,若len可以被len - next[len]整除,則最大迴圈次數n為len/(len - next[len]),否則為1。

這個是我在一篇部落格上看到的。。。不懂為什麼。。。。如果有大神知道。。。望不吝賜教!!!

AC-code:

#include<cstdio>
#include<cstring>
const int N=1001000;
char str[N];
int p[N],len;
void getp()
{
	int i=0,j=-1;
	p[i]=j;
	while(i<len)
	{
		if(j==-1||str[i]==str[j])
		{
			i++,j++;
			if(str[i]==str[j])
				p[i]=p[j];
			else
				p[i]=j;
		}
		else
			j=p[j];
	}
}
int main()
{
	while(scanf("%s",str))
	{
		if(!strcmp(str,"."))
			break;
		len=strlen(str);
		getp();
		if(len%(len-p[len])==0)
			printf("%d\n",len/(len-p[len]));
		else
			printf("1\n");
	}
	return 0;
}