1. 程式人生 > >【笨方法學PAT】1108 Finding Average (20 分)

【笨方法學PAT】1108 Finding Average (20 分)

一、題目

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number

 where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y
. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

二、題目大意

給定一串字串,判斷是否符合數字的要求。

三、考點

string

四、注意

1、逐個判斷;

2、輸出的時候判斷num的個數。

五、程式碼

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
bool judge(string s) {
	//char
	for (int i = 0; i < s.length(); ++i) {
		if (isdigit(s[i]) || s[i] == '.')
			continue;
		if (i == 0 && s[i] == '-')
			continue;
		return false;
	}

	//.
	int num = 0;
	for (int i = 0; i < s.length(); ++i) {
		if (s[i] == '.') {
			num++;
		}
	}
	if (num > 1)
		return false;

	//decimal
	int i;
	for (i = 0; i < s.length(); ++i) {
		if (s[i] == '.') {
			if (s.length() - i - 1 > 2)
				return false;
		}
	}

	return true;
}
int main() {
	//read
	int n;
	cin >> n;
	float sum = 0.0;
	int num = 0;
	for (int i = 0; i < n; ++i) {
		string s;
		cin >> s;
		bool flag = judge(s);
		//judge [-1000,1000]
		if (flag == true) {
			float f = stof(s);
			if (f > 1000||f<-1000)
				flag = false;
			else {
				sum += f;
				num++;
			}
		}
		
		if (flag == false) {
			printf("ERROR: %s is not a legal number\n", s.c_str());
		}
	}
	if(num==1)
		printf("The average of %d number is %.2f\n", num, sum*1.0 / num);
	else if (num != 0) {
		printf("The average of %d numbers is %.2f\n", num, sum*1.0 / num);
	}
	else
		printf("The average of 0 numbers is Undefined\n");

	system("pause");
	return 0;
}