1. 程式人生 > >【笨方法學PAT】1121 Damn Single (25 分)

【笨方法學PAT】1121 Damn Single (25 分)

一、題目

"Damn Single (單身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

二、題目大意

跟男女朋友名單和出席的人,判斷單身狗和只有一個人的人的名單。

三、考點

陣列

四、注意

1、使用陣列儲存情侶關係;

2、單身或者TA沒有參加的都列為單身狗。

五、程式碼

#include<iostream>
#include<map>
#include<set>
#include<vector>
#define N 100001
using namespace std;
int n1[N] = { -1 };
bool show[N] = { false };
int main() {
	//read
	int n;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		int a, b;
		cin >> a >> b;
		n1[a] = b;
		n1[b] = a;
	}

	int m;
	cin >> m;
	vector<int> v(m);
	set<int> sset;
	for (int i = 0; i < m; ++i) {
		cin >> v[i];
		show[v[i]] = true;
	}

	//solve
	for (int i = 0; i < m; ++i) {
		//damn
		if (n1[v[i]] == -1) {
			sset.insert(v[i]);
			continue;
		}

		//just one
		if(show[n1[v[i]]]==false) {
			sset.insert(v[i]);
			continue;
		}
	}

	//output
	cout << sset.size() << endl;
	for (auto it = sset.begin(); it != sset.end(); ++it) {
		if (it != sset.begin())
			cout << " ";
		printf("%05d", *it);
	}

	system("pause");
	return 0;
	
}